SourceForge has been redesigned. Learn more.

End/Beginning of loop flicker

  • cian

    cian - 2005-10-04

    I posted this in the "Full screen smooth looping video possible?" thread but figure it may have get lost there and probably deserves a thread of its own.
    I'm seeing a flicker between loops when using mplayerplug-in with loop="true" in the embed tag. It's only for a fraction of a second, and looks like a white screen, but it's definitely there. My understanding is that this has been fixed and shouldn't happen, and indeed with debugging turned on I get the following in the output:

    mplayer -wid 0x3c00138 -vo xv -user-agent NSPlayer -osdlevel 0 -nojoystick -noconsolecontrols -cookies -slave -loop 0 -fixed-vo -rtsp-stream-over-tcp -nomouseinput /home/cian/movies/theshapeofdays/
    in sendcommand - command get_time_length

    It's my understanding that the "-fixed-vo" option should prevent this flicker, and it does when I call mplayer from the command line. I'm using mplayer svn, mplayerplug-in svn, firefox 1.0.7, and FC4. Can anyone else confirm, deny or explain this behaviour?


    • Kevin DeKorte

      Kevin DeKorte - 2005-10-04

      Have you tried other vo's like x11 or gl? Also you might want to make sure you have an upto date version of mplayer. The bug you are seeing is completely contained within mplayer, the plugin should have nothing to do with the flicker.

    • cian

      cian - 2005-10-04

      I've tried x11, xv, gl, and a few others I found in the mplayer man page (xv does not always autoplay though, and gl is too much for crappy graphics card).
      I literally take the above debugging output, paste it to the command line, remove the "-wid 0x3c00138" bit, and mplayer loops the video nice and smoothly. If mplayer plays ok like this is it likely to be an mplayer issue?


Log in to post a comment.