• aminmo

    aminmo - 2004-12-29

    Hi guys,
    I am new to this and found some quirks with the plugin that has gone unexplained in the documents. First of all I went to apple trailers site and chose a movie to watch. The pllugin kicked off but seemingly tried to cache the entire movie before playing it. So I grew tired of waiting and went to change the mplayerplug-in.conf. here I noticed nomediacache=1 solves the problem and the movies starts playing right away but without caching and frequent pauses. Then I tried download=0 and disabled nomediacache. No change at all and it again started downloading the whole movie. So my question is which parameters optimal for embeded playback in my situation?
    The second Question is why can't I play windows media movies in

    Here's my mplayerplug-in.conf:

    Unfortunatly nothing gets logged in mpp.log, am I missing something here?

    • Kevin DeKorte

      Kevin DeKorte - 2004-12-29

      Here is the mplayerplug-in.conf file that I use


      I think you need to read the configuration page a little closer. logfile and download are both depreciated options and do not do anything anymore. How to get output when debug is enabled is in the mailing list search for debug=1 in it.

      The nomediacache option should only be used on local high speed >= 100MBps networks or when you are playing media from your local disk.

      As for the mms data streams I would guess you don't have the optional "essential" codecs package installed for mplayer.

    • aminmo

      aminmo - 2004-12-29

      Thanks for the hint. But the thing is that it seems to ignore the cachesize setting. I am a dial-up user :( and every time I choose a "small" movie the plugin caches at least 1MB before starting to play, no matter what I choose for cache size. This is hugely overkill for me (remember it takes some 3-4 minutes for the cache to build up and interruptions are more than likely on 56k line). This thing is not optimized for low bandwidth.

      • Kevin DeKorte

        Kevin DeKorte - 2004-12-30

        Your right in that mplayerplug-in is not optimized for dialup connections. It can be tuned some, but basically if you don't want stuttering video you have download more, but if you want it to start quicker, you may have stuttering video. Also, some media does not play properly with very little data downloaded. You might try setting the "cache-percent" option to something like 5 to 10, but I think you will have definate video stuttering problems.

    • aminmo

      aminmo - 2004-12-30

      Kevin, I've got another problem too.
      I can watch but I can't watch any of the qt or wmv trailers of Instead I get media mismatch error message. What's wrong with the plugin this time?

      • Kevin DeKorte

        Kevin DeKorte - 2004-12-31

        Please give a specific URL or movie title that does not work. There are some Windows Media files that I cannot get to work at yahoo because yahoo is not identifying the browser as being able to play the media. So mplayerplug-in is never started.

    • aminmo

      aminmo - 2004-12-31

      It is a general symptom in Yahoo Movies. However, to be specific, try this url:
      then try either of quicktime or windows media links.

      • Kevin DeKorte

        Kevin DeKorte - 2005-01-02

        The windows media works fine on my machine and the quicktime media does not. I knew the quicktime did not work and it is something I am looking into, but it is not high on the priority list at the moment since the Windows Media works.


Log in to post a comment.