#36 firefox 0.8 crash with mplayerplug-in 2.6

closed-works-for-me
nobody
Plugin (92)
5
2004-05-04
2004-05-02
Anonymous
No

When viewing trailers at apple.com/trailers, Firefox
0.8 crashes when trying to view any movie. These are
the errors that are outputed:

(Gecko:7079): Gtk-CRITICAL **: file gtkwindow.c: line
925 (gtk_window_new): assertion `type >=
GTK_WINDOW_TOPLEVEL && type <= GTK_WINDOW_POPUP' failed

(Gecko:7079): Gtk-CRITICAL **: file gtkwidget.c: line
5218 (gtk_widget_set_usize): assertion `GTK_IS_WIDGET
(widget)' failed

(Gecko:7079): Gtk-CRITICAL **: file gtkwidget.c: line
4101 (gtk_widget_get_style): assertion `GTK_IS_WIDGET
(widget)' failed

The plugin works fine in plain vanilla Mozilla 1.6. My
MPlayer version is 1.0pre4 on RH9.

Discussion

  • Kevin DeKorte

    Kevin DeKorte - 2004-05-04
    • status: open --> closed-works-for-me
     
  • Kevin DeKorte

    Kevin DeKorte - 2004-05-04

    Logged In: YES
    user_id=685413

    Make sure that the GTK widget toolkit of mplayerplug-in,
    mozilla and firefox all match. Or try the current CVS
    version as it will not crash but give an error message.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks