#8 Build for pre Pentium 3 CPUs

closed
MPlayer (34)
5
2008-05-26
2008-02-20
ikk
No

Hello.

Please relese build without SSE, only with MMX: 1 MMX2: 1.

I'm asking for this because I'm running Pentium Celeron 700 MHz processor and I got bad playback performance with .wmv files.

SSE instructions has been added in Pentium 3, thus I figured out it could increase performance on systems with pre P3 cpu's.

I tested:

[code]
MPlayer 1.0rc1-3.4.2 (C) 2000-2006 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Model: 8, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.
[/code]

and

[code]
MPlayer Sherpya-SVN-r25803-4.2.2 (C) 2000-2008 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Model: 8, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE
[/code]

Having tried many builds, my conclusion is that mplayer compiled with only "MMX: 1 MMX2: 1" would work.

Basically, on "MPlayer Sherpya-SVN-r25803-4.2.2" video freezes forever, while on "MPlayer 1.0rc1-3.4.2" playback is quite smooth.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    Don't the "MPlayer-rtm-svn-xxxxx.7z" builds (Runtime CPU Detection) work with CPU's without SSE ???

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-03-02

    Logged In: YES
    user_id=38409
    Originator: NO

    Oo
    I make make sometimes a build, added another build on my chain is not so good, I already build 4 MPlayer 4 MEncoder 1 MPlayer GUI and 1 ffmpeg, perhaps are you sure your cpu misses SSE?

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-04-01

    Logged In: YES
    user_id=38409
    Originator: NO

    I cannot make always builds for pre p3, but I could build one for you
    can you please post the output of
    http://oss.netfarm.it/mplayer/misc/cpuinfo.exe

    anyway it's very strange you cpu does not have sse

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-04-01

    Logged In: YES
    user_id=38409
    Originator: NO

    I cannot make always builds for pre p3, but I could build one for you
    can you please post the output of
    http://oss.netfarm.it/mplayer/misc/cpuinfo.exe

    anyway it's very strange you cpu does not have sse

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-04-06

    Logged In: YES
    user_id=38409
    Originator: NO

    I suspect previous builds was done by using mtune=native instead of p3
    can you please check if latest ones are working?

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-04-13

    Logged In: YES
    user_id=38409
    Originator: NO

    I suspect past version was all compiled using athlon as target, can you test latest rev 26430 pls?

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-04-14

    Logged In: YES
    user_id=38409
    Originator: NO

    can you check if latest p3 build work please? thanks

     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-05-26
    • status: open --> closed
     
  • Gianluigi Tiesi

    Gianluigi Tiesi - 2008-05-26

    Logged In: YES
    user_id=38409
    Originator: NO

    please reopen if needed

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks