#11 Wrong bitrate with mod_mp3-streams

closed-fixed
Joe Drew
Networking (5)
5
2002-07-14
2002-02-23
No

Hi there,

I use mpg321 as provided by the RedHat 7.2
installation and also recompiled the newest version.

When playing streams from a mod_mp3-server they are
played a lot too fast, though I can't say if it's
double or even faster.

mpg123 plays them correctly.

Greets

Discussion

  • Joe Drew

    Joe Drew - 2002-03-27

    Logged In: YES
    user_id=330927

    Hi, thanks for the report.

    Could you do two things for me: First, test this out with
    version 0.2.10, and second, give me the URL to the site
    you're using if there's still a problem? Networking support
    was enhanced recently, and I'm not sure what version you
    tested against.

    Thanks!

     
  • Peter H. Ruegg

    Peter H. Ruegg - 2002-03-28

    Logged In: YES
    user_id=94673

    Hi there,

    I used version 0.2.3 then. 0.2.10 does handle it a lot
    better. It's now mainly played at the correct speed,
    although it still has a small faster hickup every few
    seconds (between 1 and ~15).

    Sadly I can not give you the URL, as it's on an internal
    LAN, but it's streamed by mod_mp3 0.35 on Apache 1.3.23
    on RedHat 7.2 with a 2.4.18-pre8-ac3 if that helps :-)

    Thanks for the good work!

     
  • Joe Drew

    Joe Drew - 2002-07-14
    • status: open --> closed-fixed
     
  • Joe Drew

    Joe Drew - 2002-07-14

    Logged In: YES
    user_id=330927

    The hiccups are definitely because of the lack of buffering
    in mpg321, and are going to be fixed when I get around to it
    for 0.3.0. 0.2.10 fixed these issues, so I'm going to close
    this.

    Thanks for the report!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks