#10 mpg321-0.2.3 dos'nt comp. with libao-0.7

closed-invalid
Joe Drew
5
2002-02-21
2002-02-21
Anonymous
No

mpg321-0.2.3 does not compile with libao-0.7.0 from
Vorbis-1.0rc1., in ao/ao.h there is a typedefs
ao_info_t and a function prototype ao_get_driver_info,
ao.c of mpg321 expects ao_info ao_driver_info. The
return type of ao_driver_info should have a component
'type', which is not a component ao_get_driver_info.

Any idea?

Juergen

Discussion

  • Joe Drew

    Joe Drew - 2002-02-21

    Logged In: YES
    user_id=330927

    mpg321 requires libao 0.8.0 or higher. It's a requirement;
    libao 0.8.0 is source-incompatible with all previous
    versions. Sorry.

     
  • Joe Drew

    Joe Drew - 2002-02-21
    • status: open --> closed-invalid
     

Log in to post a comment.