Unable to create a parser : error code

  • lixing

    lixing - 2008-09-26

    Hi, I am glad to see dapper provides such a good parser. But when I execute the example,  it always shows

          Unable to create a parser : 80040154

    But if I run this example in another computer, sometimes it can work.

    I checked out the latest code from svn, if I run any example, the error is:

          Failed to initialize parser: Failed to instantiate nsICharsetConverterManager: 80040154

    Do you have any idea about this issue? I want to use this great parser, but always run into problem.

    Thank you in advance.

  • Brian Levine

    Brian Levine - 2010-02-11

    I know it's been ages since the above post, but in case anyone else runs into the same problem and aren't on a windows machine, there seems to be some kind of dependency on win code.  (if you do a search for that error code, there's lots of stuff about registering COM components and stuff like that).

    Unfortunately, I don't have any kind of work around and am close to moving on to a different parser…


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks