Installation step-by-step would be helpful

Help
quixote9
2011-12-07
2013-04-24
  • quixote9

    quixote9 - 2011-12-07

    I'm not sure one is necessary for Win/Mac (that seems to be a double-click operation), but on Linux (Mint Debian squeeze) I ran into the following issues:

    1) Is it best to install as superuser? I installed as user, and it wants the path to java set in my ENV. I'm not even sure where java lives (seems to be in /usr/lib/jvm/java-6-sun-1.6.0.26/bin/java ?). Obviously I can setenv, but would installing as root avoid all that? (It's a single user machine. I don't care which user I install as.)

    2) Is a database like mysql a dependency? Or optional?

    3) What are the dependencies I should check for first? If there's a list, I haven't found it, and it's not in the readme.txt once the tar.gz is unpacked.  Maybe there are none, but since the first run led straight to a complaint about paths, I'm expecting a typical *nix progression of dealing with an interminable series of showstoppers. :D

    4) And then, once it's running, maybe this is obvious. But will it accept data from a market quotes service? If only a few, which ones?

    Thanks! Looks like a dynamite program and I'd love to get it working!

     
  • Mark Hummel

    Mark Hummel - 2011-12-08

    I haven't used Linux in quite a long time so my answers are suggestions only:

    1) My feeling is that installing as the root user would not help because for security reasons $PATH would be shorter. So you'd have to do more fiddling with environment variables rather than less.

    In addition to adding the Java Runtime to your $PATH, you may also need to set $ANT_HOME - depending on which version you downloaded;

    2) A database is optional, but I would use MySQL or PostgreSQL, particularly if you have a large data set;

    3) All required .jar SHOULD be in ./lib - having said that I have forgotten to add things before. What is the output when you run the following command: 'java - jar venice.jar' on the command line?

    4) The last time I checked, the Yahoo quote import was working. But it's not actively maintained, so the interfaces could have changed. Importing from files does work however.

    I hope this helps,
    Mark.

     
  • quixote9

    quixote9 - 2011-12-09

    Thanks for that! I'll give it a whirl tomorrow and report back.

     
  • quixote9

    quixote9 - 2011-12-15

    Well, it took a lot longer than "tomorrow."  When I ran it from command line using 'java - jar venice.jar' it worked!  So my problem is obviously not having java runtime in my $PATH.

    Now I just need to figure out how to actually use the program. :D

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks