------------------------------

Message: 4
Date: Fri, 20 Oct 2006 19:44:36 +0300
From: "Jarkko Nieminen" <jarkkoniem@gmail.com>
Subject: [Motion-user] Problem with ftp upload
To: Motion-user@lists.sourceforge.net
Message-ID:
        <5d5a6de80610200944m4f765a04qde44e30eaacdb859@mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

I am trying to make motion upload every picture it takes.
I have the following line in my motion.conf
on_picture_save = /root/ftpput.sh %f

and the ftpput.sh script looks like this
#!/bin/sh
ftp -n 123.123.123.123 <<END_SCRIPT
quote USER valvonta
quote PASS valvonta
put $ 1
quit
END_SCRIPT
exit 0


The script works fine if I run it separately but with motion.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://sourceforge.net/mailarchive/forum.php?forum=motion-user/attachments/20061020/755ca574/attachment.html

------------------------------

Message: 5
Date: Fri, 20 Oct 2006 18:58:14 +0200
From: "Harald Klemm" <HK@EmptySoft.net>
Subject: Re: [Motion-user] Problem with ftp upload
To: "Motion discussion list" <motion-user@lists.sourceforge.net>
Message-ID: <005f01c6f468$f01c4b00$01040b0a@pcharald>
Content-Type: text/plain; charset="iso-8859-1"

Hi Jarkko.!

in your script try

/usr/bin/ftp -n 123.123.123.123 <<END_SCRIPT

or where or ftp is located, then in schold work fine

BYe
     Harald

http://EmptySoft.net
http://www.BoulderHoelle.at
---
Wie viele Dinge es doch gibt, die ich nicht brauche! (Sokrates)
  ----- Original Message -----
  From: Jarkko Nieminen
  To: Motion-user@lists.sourceforge.net
  Sent: Friday, October 20, 2006 6:44 PM
  Subject: [Motion-user] Problem with ftp upload


  I am trying to make motion upload every picture it takes.
  I have the following line in my motion.conf
  on_picture_save = /root/ftpput.sh %f

  and the ftpput.sh script looks like this
  #!/bin/sh
  ftp -n 123.123.123.123 <<END_SCRIPT
  quote USER valvonta
  quote PASS valvonta
  put $ 1
  quit
  END_SCRIPT
  exit 0


  The script works fine if I run it separately but with motion.



------------------------------------------------------------------------------

I tried that but motion still does not send images to the ftp server.
And again if I run the script separately it works fine,