Thanks for your help gentlemen

The background to my problem:-

I  tried the apt-get install motion on Ubuntu 10.04 released April 2010  (kernel 2.6.32-21-generic) and I can run the motion binary although it is an older version of motion.

Unfortunately The USB video class (UVC driver) webcam I use did not work (although it streams  fine in XAWTV and LUVCVIEW) creating this error:-

$  Corrupt JPEG data 584 extraneous bytes before marker 0xd9

  Next :-  I tried a newer version of Ubuntu 11.10 (kernel 3.0.0.-14-generic) and also a new motion 2.6.12 to see if this corrupt image  problem had been solved.

That is when I hit the videodev.h  error  when compiling the 2.6.12 binary.

I have not contacted Kenneth or Angel independently about the videodev.h problem. I just hope they read the mailing list and make a decision for a change.

----- Forwarded Message -----
From: Joel Avery <>
To: peter thomas <>; Motion discussion list <>
Sent: Friday, 30 March 2012, 18:11
Subject: Re: [Motion-user] videodev.h missing (why not update 3.2.12 on home page download)

If you are using Ubuntu, there is a version of motion in the Ubuntu repositories all ready to go. While it may not be up to date, it is hassle free.

Just type "sudo apt-get install motion" and you are ready to go by putting some final touches in the motion.conf file.

From: peter thomas <>
To: "" <>
Sent: Friday, March 30, 2012 8:47:25 AM
Subject: [Motion-user] videodev.h missing (why not update 3.2.12 on home page download)

Is there a good reason why the motion home page (where every new person starts) with latest version download 3.2.12  has not been updated to prevent videodev.h error occuring whilst building the binary.

I am relatively new to linux using Ubuntu 11.10 and when this occurs and when I  find a solution in the forum as below. I do not understand what is a svn or git?  I just wanted it not to be broken for a first time use by a  newbie.

Can someone give me the time to point me in the right way to get motion working (before I like presumably many others have to walk  away from a great piece of software).

for the error:
linux/videodev.h: No such file or directory

Fix record

Update to svn or git version , where it has been fixed. Cheers, -- AngelCarpintero - 19 Feb 2012

This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
Motion-user mailing list