Compiling

Help
Roy
2010-12-18
2013-04-30
  • Roy

    Roy - 2010-12-18

    I'm trying to compile MGE, with Visual Studio 2010. I was trying with an older version of the directx sdk, but I couldn't get Distant Land to show up, so I installed a slightly newer version (June 2010) and now if I enable Distant Land in the GUI it crashes after the intro video (but it shows the version number in the corner, before that). Fullscreen shaders and other things seem to work. Any ideas?

     
  • Roy

    Roy - 2010-12-18

    Also, the post-build fxc lines fail with
    EXEC : error X3501: 'main': entrypoint not found

     
  • Europop

    Europop - 2010-12-18

    Which of the projects you tried to compile? What number of revision you tried to compile? If after rev178 then you should add new textures for use MGE with Distant Land.
    I haven't tried to compile MGE in VS 2010. Current sln, vcproj and csproj files of the project are intended for VS 2008. Although I don't see problem in this.
    I will remind that there is well written help on related subjects https://sourceforge.net/apps/mediawiki/morrgraphext/index.php?title=MGE_Source_Code

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks