From: Josef Svitak <jsvitak@ya...> - 2006-08-18 03:49:22
The problems with compiling using gcc 4.1 vs 4.0 stem from stricter adherence
to the C99 Ansi Standard. Code which slipped by under '-pedantic' in earlier
versions will no longer compile on 4.1 and later. However, code which compiles
cleanly on 4.1 should compile cleanly in earlier versions.
There doesn't seem to be any set of flags that allows this code to compile, so
the short term fix is to use an older version of the compiler. The longer term
fix is to fix the sticky spots in the code. I'll fork a topic on that...
On Wed, August 15, 2006 4:45 pm, Upinder S. Bhalla said:
> I am using g++ (GCC) 4.0.3 (Ubuntu 4.0.3-1ubuntu5) on
> Linux version 2.6.15-26-686.
> I checked against the version in the SourceForge repository. It is the
> same. So it seems to be a compiler issue.
> I guess I need to set up a preliminary compile set on a group of lab
> machines. I'll see if anyone in the lab has FC5 running.
> I have flex 2.5.31
On Tue, August 15, 2006 1:36 am, Josef Svitak said:
> Moose will not compile on g++-4.1 on FC5. Not sure how far-reaching this
> problem is. Compiling with g++32 (compatibility version 3.2) gets farther
> but dies on the --c++ flag to flex++ (version 2.5.4).
Get latest updates about Open Source Projects, Conferences and News.