Hey Kai,
You need to also modify some Python files.  I have an upgrade guide that will help you here (also linked from the moin download page).  Pay attention to the FastCGI section:
http://moinmo.in/RickVanderveer/UpgradingFromMoin17ToMoin18

-Rick




On Wed, Dec 31, 2008 at 4:20 AM, kai@aplteam.com <kai@aplteam.com> wrote:
I tried to upgrade from 1.7.1 to 1.8.

I am running MoinMoin under WIndows/Apache with FastCGI.

After running

python setup.py install

I restartet both, Apache and FastCGI.

I get a 500 (Server Error)

The apache log contains this bit of information:

[Wed Dec 31 11:11:22 2008] [error] [client 87.106.54.209] FastCGI:
incomplete headers (0 bytes) received from server
"D:/Wikis/apl2/moin.fcg", referer:
http://aplteam2.com/aplwiki/Frontpage

I compared my moin.fcg with the latest one but cannot see any reason
why it fails to work under 1.8

Any ideas?

Kai

------------------------------------------------------------------------------
_______________________________________________
Moin-user mailing list
Moin-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/moin-user