#40 RSS Feed broken

closed-out-of-date
None
5
2004-03-27
2003-10-21
No

The RSS feed for my moin wiki has been working quite well
for a while (not very long, this wiki has been up for about a
week), but yesterday it stopped working and now gives a
traceback:
http://just.letterror.com/ltrwiki/
RecentChanges?action=rss_rc

Discussion

  • Thomas Waldmann

    Thomas Waldmann - 2003-10-21

    Logged In: YES
    user_id=100649

    Hi Just,

    thanks for your bug report. I looked shortly into it, but
    can only find that that "None" being used as index is the
    reason for your problem, but not where that comes from exactly.

    Maybe try the following:
    * upgrade moin to nightly cvs (has release quality and is
    far better than what you run now)
    * try using python 2.2 or 2.3 (you currently run moin with
    2.4a0), just edit the first line of moin.cgi

    If you succeed, please post it here.

    Thomas

     
  • Just van Rossum

    Just van Rossum - 2003-10-21

    Logged In: YES
    user_id=92689

    I upgraded to the nightly CVS version, but the problem persists.

    That Python 2.4a0 is pretty much 2.3 final: I installed from CVS
    just after 2.3 was released.

     
  • Just van Rossum

    Just van Rossum - 2003-10-22

    Logged In: YES
    user_id=92689

    Sorry, I had to downgrade again to 1.0 for various reasons, and
    I'll just live with a broken RSS feed for now.

    Main reason to downgrade: #!python snippets are now in a table,
    but we're using a non-standard CSS to get pretty tables, but this
    messes up the code snippets in 1.1. Also: in 1.1 I couldn't find
    where the line numbers are generated, whereas in 1.0 it was
    simple (and documented by google). I _don't_ want line
    numbers...

     
  • Jürgen Hermann

    Jürgen Hermann - 2003-10-22
    • assigned_to: nobody --> jhermann
     
  • Jürgen Hermann

    Jürgen Hermann - 2003-10-22

    Logged In: YES
    user_id=39128

    Just, did you iinstall pyxml, and if yes what version?

     
  • Just van Rossum

    Just van Rossum - 2003-10-22

    Logged In: YES
    user_id=92689

    Nope, no PyXML installed. I did "downgrade" my CVS Python
    (2.4a0, snapshot shortly after 2.3 was released) to 2.3.2.

     
  • Thomas Waldmann

    Thomas Waldmann - 2004-03-27
    • status: open --> closed-out-of-date
     
  • Thomas Waldmann

    Thomas Waldmann - 2004-03-27

    Logged In: YES
    user_id=100649

    unclear if the problem still exists in moin 1.2.x.

    please re-submit / re-open if you experience this problem
    with later moin versions.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks