Hello Ian,

Yes. i found some issue in standalone module for Apache 2.4. I think it is fixed now
I uploaded a new tarball for testing: http://www.modsecurity.org/tarball/2.7.5/modsecurity-apache_2.7.5.tar.gz

Could you retry ?



On Thu, Jul 18, 2013 at 6:01 PM, Ian Webb <perelman42@gmail.com> wrote:
On Thu, Jul 18, 2013 at 4:25 PM, Breno Silva <breno.silva@gmail.com> wrote:
> Do you have multiple apache versions in this box ? If so.. make sure you ara
> using the right apache version devel tools and code.
> For some reason i think mod_security is using apache 2.3 or 2.4 files.
> Thanks

I had only 2.4 installed, and ModSecurity 2.7.4 compiled fine but
2.7.5 would not compile.

I just tried uninstalling Apache 2.4 entirely and installing Apache
2.2; now 2.7.5 compiles correctly.


See everything from the browser to the database with AppDynamics
Get end-to-end visibility with application monitoring from AppDynamics
Isolate bottlenecks and diagnose root cause in seconds.
Start your free trial of AppDynamics Pro today!
mod-security-developers mailing list
ModSecurity Services from Trustwave's SpiderLabs: