mod_mce kernel panic

  • loungelircer

    loungelircer - 2007-08-02


    I've been up late for a few nights in a row unsuccessfully trying to get my microsoft remote keyboard working with lirc_mod_mce and then mod_mce when lirc_mod_mce didn't work.

    The symptoms: After I modprobe the kernel module (lirc_mod_mce or mod_mce) the keyboard and mouse work perfectly for a short time then I get a system lock with the Caps Lock light flashing on my wired keyboard. I have tried loading the module at startup without another keyboard or mouse plugged in and the freeze still happens.

    I compiled the mod_mce module with debug=1 set in mod_mce.c, then  in a terminal (using ctrl+alt+F1) instead of under x, I loaded the module and inserted the philips receiver. After a period of typing random things in the terminal and wiggling the mouse stick I got a kernel panic. I wrote down the text that I could see and here it is for anyone that knows more about this stuff than I do:

    "BUG: unable to handle kernel NULL pointer dereference at virtual address 00000002

    printing eip:

    Recursive die() failure, output suppressed
    Kernel panic - not syncing: Attempted to kill the idle task"

    I tried again in the terminal and got the exact same message, except for the following lines:


    I'm really hoping someone can make something from all of this, I've just bought a nice new system to make a media centre and I dread having to give up and go to windows for hardware compatability.

  • jon

    jon - 2010-12-10

    Well, it's three years since you posted, and I've only started trying to maintain this stuff recently, but you might like to give v0.3.1 a go.



Log in to post a comment.