Images not cached by browser

Help
Anonymous
2003-01-20
2003-06-18
  • Anonymous - 2003-01-20

    Hi.

    It seems like images on websites running mod_gzip are not cached by the browser. The images appear in the apache access_log for every page view where the image is. The images are excluded from being compressed by the mod_gzip configuration (and image files don't appear in the mod_gzip log).

    I have tried to place the exact same simple html file with an image on two different virtual hosts on the the same server. One with, and one without mod_gzip turned on. The image is only cached where mod_gzip i turned off.

    I'm using mod_gzip/1.3.26.1a with Apache/1.3.27 on Linux/RH 7.2. I have used the configuration shown on http://www.schroepl.net/projekte/mod_gzip/config.htm (where image files are excluded from being compressed).

    Does anyone have a solution for this problem?
    Suggestions are appreciated

    Regards

    Thomas

     
    • Erik Arvidsson

      Erik Arvidsson - 2003-06-08

      The problem is in the Vary header. IE is having trouble with this for images. I'm trying to figure out how to NOT include this header field when the files are NOT zipped.

       
    • Anonymous - 2003-06-17

      Have you tried this directive : (I did not tried it yet, hint in mod_gzip documentatin about Caching)

      <FilesMatch \.gif$>
      mod_gzip_on No
      <FilesMatch>

       
    • james baker

      james baker - 2003-06-18

      To anyone who is having trouble displaying images once mod_gzip is installed this offers a workaround.

      <FilesMatch ".(gif|jpg)">
         mod_gzip_on No
      </FilesMatch>

      In my case, once I installed mod_gzip, all images I served up were displaying fine, but anyone who tried to save them using Internet Explorer was unable to save as source format (jpg) and instead were only offered the option to save as .bmp... adding the above code to my httpd.conf fixed it.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks