Fatal Error with mod_gzip 1.3.26.1a

Help
Anonymous
2003-02-01
2003-02-11
  • Anonymous - 2003-02-01

    I'm currently using Apache version 1.3.26 and 1.3.19.1a for mod_gzip.  We want to upgrade to version 1.3.26.1a so we have a matching version and to see if it alleviates some issues we're seeing with 1.3.19.1a.

    I downloaded the mod_gzip.so from your site, placed it in the libexec directory, then tried to startup Apache.  I received the following error:

    Cannot load /usr/local/apache/libexec/mod_gzip.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: /usr/local/apache/libexec/mod_gzip.so: wrong ELF data format: ELFDATA2LSB
    ./apachectl start: httpd could not be started

    We're currently using this on a Solaris 8 system.  Any help would be great!  Thanks.

    Regards,
    Cory

     
    • S. Staats

      S. Staats - 2003-02-11

      I'm guessing that is because the mod_gzip.so was compiled for an i386 and not SPARC.  If you have a gcc compiler on your Solaris box, just download the source code for mod_gzip and go from there.  If you don't have gcc for Solaris, you can get it at http://www.sunfreeware.com

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks