installation problem

Help
Anonymous
2003-01-28
2003-02-11
  • Anonymous - 2003-01-28

    I tried to install an run mod_gzip on SUSE 8.1. Everything seemed to work until starting apache 1.3.26, it says
    cannot load /usr/lib/apache/mod-gzip into server: /usr/lib/apache/mod_gzip.so: undefined symbol: gzp_main

    To compile mod_gzip i had to install the apache-devel package in SUSE, without it, no apxs is installed. Then i started installation with
    /usr/sbin/apxs -i -a -c mod_gzip.c
    after calling apxs it says:
    gcc -02 -march=i586 -mcpu=i686 -fmessage-length=0 -DEAPI_MM -fPIC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHARF_SERVER_LIMIT=2048 -DDYNAMIC_MODULE_LIMIT=128 -DLINUX=22 -DMOD_SSL=208110 -DEAPI -fPIC -DSHARED_MODULE -I/usr/include/apache -c mod_gzip.c
    gcc -shared - o mod_gzip.so mod_gzip.o
    usw..

    In der httpd.conf LoadModule and AddModule was added. But it was added in the <IfDefine DUMMYSSL> statement. Instead I was placing both outside it, to load in all cases.

    Then I added the mod_gzip Configuration

    <IfModule mod_gzip.c>
    mod_gzip_on Yes
    ...
    </IfModule>

    Please help, i really dont know whats wrong with it. i tried to install mod_gzip-1.3.26.1a

    thanks

     
    • S. Staats

      S. Staats - 2003-02-11

      In the directory where you untarred the mod_gzip-1.3.26.1a.tar.gz file, modify the Makefile file and set
      APXS=/usr/sbin/apxs
      then type:
      make build
      make install
      It will probably install the "LoadModule gzip_module        libexec/mod_gzip.so" and "AddModule mod_gzip.c" lines in the DUMMYSSL section of httpd.conf, so just move them out again.
      Make sure mod_gzip.so is in the libexec directory.
      That should work for you.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks