Trouble un'tar'ing mmi_pd_040526.tar.gz

Help
Phil
2004-07-27
2004-07-28
  • Phil

    Phil - 2004-07-27

    I have been unable to untar mmi_pd_040526.tar.gz as I get a checksum error and the process stops.

    I have extracted the files with -
    gunzip mmi_pd_040526.tar.gz
    tar -xvf mmi_pd_040526.tar

    The untar continues until it gets to one file which has a checksum error, and exits. I have tried this under Solaris 8, 9 and even with PKZip with identical results, and tried downloads from the following sites, again with the same results.

    puzzle.dl.sourceforge.net
    heanet.dl.sourceforge.net

    Is the fole on the server corrupted, or am I using the wrong switches for the tar command?

    Any advice will be gratefully received,

    Phil.

     
    • Lee Tavrow

      Lee Tavrow - 2004-07-28

      Another user reported a similar problem and was able to solve it by adding the "i" switch in tar which ignores checksum errors on directories.  thus try using the command:

      tar -xvfi mmi_pd_040526.tar

      I don't know what is causing a few people like you to get the checksum error.  The directory where the checksum error occurred for the other user was in an area that is not used by the programs.

      Let me know if this helps.

      lee

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks