'delete' keyboard button

  • bajtek

    bajtek - 2005-05-19

    in mlterm 'delete' keyboard button works like 'backspace' :( how to change it to work properly ?

    • MINAMI Hirokazu

      MINAMI Hirokazu - 2005-05-20

      If you are using "xterm" as a value of enviromental variable "TERM", it's because the definition of backspace and delete key on your system is not compatible to mlterm's default.

      You can change mlterm's behavour to match the definition of the keys  or use "mlterm" for TERM.

      To change how mlterm interpret BS/DEL key, see the
      [Terminal Behavior Configuration File] section of the man page.

      The value to be set varys depending on your environment and I can't tell it without more informationsuch as  the result from "infocmp" command.

      To check wether "TERM=mlterm" works,  you can run mlterm with "-y=mlterm" option. If some applications runnning the mlterm complains that "mlterm" is not available, you may have to install correponding termcap/terminfo entry. Though it's a bit complicated, I recommend this approach to avoid other problems from incompatibility.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks