Thank you Dan, my problem is solved.

In-spite of it is showing error,  the final video is being created with baseline profile.

Sorry for not being specific in my question.

On Thu, Nov 22, 2012 at 12:46 AM, Dan Dennedy <dan@dennedy.org> wrote:
On Wed, Nov 21, 2012 at 11:08 AM, s v Satyanarayana <s.sv452@gmail.com> wrote:
> Thank you,
>
> This is the command I have used
>
>  melt demo.mp4 in=0 out=300 -consumer avformat:demo2.mp4 s=480x360
> progressive=1 vprofile=baseline
>
> still I get this error
>
> [libx264 @ 0xafa614c0] [Eval @ 0xb06c999c] Undefined constant or missing '('
> in 'baseline'
> [libx264 @ 0xafa614c0] Unable to parse option value "baseline"

I am not going to help you any more than this. It works for me:

ddennedy@ddennedy-MS-7593:~/src/mlt$ melt -verbose ~/Videos/A02.mpg
-consumer avformat:test.mp4 vprofile=baseline progressive=1
strict=experimental
[producer avformat] audio: total_streams 1 max_stream 1 total_channels
2 max_channels 2
[mpeg2video @ 0x13e1bc0] warning: first frame is no keyframe
[producer avformat] audio: total_streams 1 max_stream 1 total_channels
2 max_channels 2
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5=  0| |6=  1| |7=  2| |8=  5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
|               H = back 1 minute,  L = forward 1 minute              |
|                 h = previous frame,  l = next frame                 |
|           g = start of clip, j = next clip, k = previous clip       |
|                0 = restart, q = quit, space = play                  |
+---------------------------------------------------------------------+
[mpeg2video @ 0x7fcee4009760] warning: first frame is no keyframe
[NULL @ 0x7fceec197ac0] [Eval @ 0x7fcef38ab320] Undefined constant or
missing '(' in 'baseline'
[NULL @ 0x7fceec197ac0] Unable to parse option value "baseline"
[libx264 @ 0x7fceec197ac0] using SAR=16/15
[libx264 @ 0x7fceec197ac0] using cpu capabilities: MMX2 SSE2Fast SSSE3
FastShuffle SSE4.2
[libx264 @ 0x7fceec197ac0] profile Constrained Baseline, level 3.0
[libx264 @ 0x7fceec197ac0] 264 - core 122 r2184 5c85e0a - H.264/MPEG-4
AVC codec - Copyleft 2003-2012 - http://www.videolan.org/x264.html -
options: cabac=0 ref=3 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=7
psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1
8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2
threads=12 sliced_threads=0 nr=0 decimate=1 interlaced=0
bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=250
keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf
mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40
aq=1:1.00
[mp4 @ 0x7fceec191420] Encoder did not produce proper pts, making some up.
Current Position:         65
[libx264 @ 0x7fceec197ac0] frame I:24    Avg QP:22.91  size:  8239
[libx264 @ 0x7fceec197ac0] frame P:42    Avg QP:25.71  size:  8714
[libx264 @ 0x7fceec197ac0] mb I  I16..4: 78.9%  0.0% 21.1%
[libx264 @ 0x7fceec197ac0] mb P  I16..4: 14.3%  0.0% 12.4%  P16..4:
44.2% 10.9%  3.0%  0.0%  0.0%    skip:15.2%
[libx264 @ 0x7fceec197ac0] coded y,uvDC,uvAC intra: 26.6% 73.8% 7.0%
inter: 15.4% 49.7% 0.1%
[libx264 @ 0x7fceec197ac0] i16 v,h,dc,p: 54% 21%  9% 16%
[libx264 @ 0x7fceec197ac0] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 27% 17% 21%
6%  7%  7%  5%  6%  3%
[libx264 @ 0x7fceec197ac0] i8c dc,h,v,p: 49% 20% 23%  8%
[libx264 @ 0x7fceec197ac0] ref P L0: 77.0% 14.1%  8.8%
[libx264 @ 0x7fceec197ac0] kb/s:1708.30