It seems that MH cannot create a Serial_Item on my system. After wasting a few hours of scouring the 'net and attempts at debugging the issue, I've decided to reach out to the community for help...

I have executed /usr/local/misterhouse/bin/configure as stated in the install docs, which yields:
Deleting Windows-only files...
Chmod scripts to executables...
Converting C headers to Perl headers for mh/lib/site/Device/SerialPort.pm
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory
Destination directory /usr/local/lib64/perl5 doesn't exist or isn't a directory

All done. This script is meant to work on various OSs and distributions.
Errors about missing files are not necessarily a problem.
See docs/install.html for more info.
Run mh with: ./mh


When starting MH with debugging enabled in /usr/local/misterhouse/lib/site/Device/SerialPort.pm, I see:

trying 'sys/ttycom.ph'...
Device::Serial error: Can't locate sys/ttycom.ph in @INC (@INC contains: /home/mh/code ./../code/common /usr/local/misterhouse/bin/../lib /usr/local/misterhouse/bin/../lib/site . /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/misterhouse/bin/../lib/site/Device/SerialPort.pm line 32.

trying 'termios.ph'...
Device::Serial error: Can't locate termios.ph in @INC (@INC contains: /home/mh/code ./../code/common /usr/local/misterhouse/bin/../lib /usr/local/misterhouse/bin/../lib/site . /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/misterhouse/bin/../lib/site/Device/SerialPort.pm line 32.

trying 'sys/termios.ph'...
Device::Serial error: Can't locate sys/termios.ph in @INC (@INC contains: /home/mh/code ./../code/common /usr/local/misterhouse/bin/../lib /usr/local/misterhouse/bin/../lib/site . /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/local/misterhouse/bin/../lib/site/Device/SerialPort.pm line 32.

trying 'asm/termios.ph'...
Using 'asm/termios.ph'



Simple question... How does one fix this on a 64 bit system?

Long question... Does MH really need it's own SerialPort.pm instead of one provided by the distro?


Thanks,
Rick