I would try an manally link it to some controller (switch) outside of
MH to see if it just works as a normal Insteon device.  If it doesn't
you can RMA it back to smarthome.


I finally got around to manual linking and it works just fine.  So I decided to dig into the trace more to figure out what was going on.

Here is the first command sent out to a working appliancelinc with older firmware :
26/04/2012 19:10:49  [Insteon_PLM] Executing command:0262145E900F280F:
26/04/2012 19:10:49  [Insteon_PLM] Parsing serial data: 0262145e900f280f06
26/04/2012 19:10:49  [Insteon_PLM] Parsing serial data: 0250145e900fdf4d27280f

The first is the command going out (I added this into Insteon_PLM as it was commented out)
The command portion is 280f
This command is Set Address MSB (0x28) to value 0x0f
The second line is the ack on the command (notice same command with 0x06 on end)
The third is the results from the command with the data portion being 28 0f , so it appears to just resend the command and value back.

Now however when I run this against the failing one I get this :
26/04/2012 19:22:47  [Insteon_PLM] Executing command:02621CF02A0F280F:
26/04/2012 19:22:47  [Insteon_PLM] Parsing serial data: 02621cf02a0f280f06
26/04/2012 19:22:47  [Insteon_PLM] Parsing serial data: 02501cf02a0fdf4d2728ff

The first is the command going out again, same command but different address (1cf02a)
Then the ack back
Finally the data returned, which doesn't appear correct 28 ff , it is sending back ff instead of 0f.  Not sure if this is it's way of saying there is an issue.

So, looking at this document that was dated 2007 http://www.insteon.net/pdf/INSTEON_Command_Tables_20070925a.pdf.  On page 10 you will find the description of command 0x28 'Set Address MSB' and it says : Deprecated (do not use in the future).

So if this instruction was due to be deprecated in 2007 is it possible that with my new appliancelinc it has actually been removed ?

Does the insteon branch use this same mechanism to scan the link tables ?

This still doesn't explain why simple on/off commands do not work to this device.