I am running mh 2.104 on ubuntu 8.04 (64).  It has been working great for about a year and then just stopped working.  It seems not to be running on boot up.  When I run sudo /opt/mh/bin/mh from a command line it seems to work great, but runs in a nice graphic window I have never seen before. Normally mh runs at boot by the following file /etc/init.d/mh which points it to /opt/bin/mh/bin/mh.sh which then runs mh.  the log file /opt/mh/data/mh.log shows a "couldn't connect to display :0" error which is the same error I get when running mh in a terminal as the mh user.  I am guessing that for some reason mh is trying to run with a window and the mh user does not have permissions to open a window on the display.  I am not sure what I did to break that.  Can anyone help.  Bellow are the last few lings of the mh.log file, the entire /etc/init.d/mh script and the entire /opt/mh/bin/mh.sh startup script.
Thanks in advance.


 - setting up main window
No protocol specified
couldn't connect to display ":0" at /usr/lib/perl5/Tk/MainWindow.pm line 55
MainWindow->new() at /opt/mh/bin/mh line 6393

file /etc/init.d/mh

#! /bin/sh

# Starts and stops misterhouse

# Misterhouse automatically generates a PID file here:
# Use this command to start the proxy
# this just calls another script that does the real work
# Start mh
 echo "Starting Misterhouse"
start-stop-daemon --start --background --quiet --chuid mh --exec $DAEMON

 echo ""
# Stop mh
 echo "Stopping Misterhouse"
 start-stop-daemon --stop --quiet --pidfile $PID
case "$1" in
 sleep 5
*) # Display a usage option.
 echo "Usage: /etc/init.d/mh {start|stop|restart}"
 exit 1
exit 0

file /opt/mh/bin/mh.sh

#! /bin/sh

# This is the script used to start misterhouse. It is called at boot by /etc/init.d/mh
export mh_parms=/opt/mh/bin/mh.private.ini
# Start misterhouse
/opt/mh/bin/mh > /opt/mh/data/mh.log 2>&1 &