On Apr 28, 2013, at 8:17 PM, Jim Duda wrote:

On 04/28/2013 11:52 AM, Brandon Price wrote:
I tried a few things to no avail, took me a sec to backup my system and upgrade.
1. I upgraded to Ubuntu 13.04 and am now running the following package versions:
sphinxbase 0.8-0
pocketsphinx 0.8.0

2. I made sure that the new pocketsphinx_continuous binary is dynamically linked to the pulseaudio libraries.
root@hostname:~# ldd /usr/bin/pocketsphinx_continuous | grep pulse
        libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f6e6a3e5000)
        libpulse-simple.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-simple.so.0 (0x00007f6e6a1e1000)
        libpulsecommon-3.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-3.0.so (0x00007f6e69b57000)

That got me a bit further and I was able to try looking at the command that misterhouse runs and running that manually, its a long one:

//usr/local/bin/pocketsphinx_continuous -host localhost -port 3235 -log_file /usr/local/src/misterhouse-stable/data/pocketsphinx/pocketsphinx -sent_file /usr/local/src/misterhouse-stable/data/pocketsphinx/current.sent -lm_file /usr/local/src/misterhouse-stable/data/pocketsphinx/current.lm.DMP -hmm_file /usr/local/share/pocketsphinx/model/hmm/en_US/hub4wsj_sc_8k -program /usr/local/bin/pocketsphinx_continuous -device default -sample 16000/

The full output is really long so I pasted it here <http://pastebin.com/x6PNzgWa>. It looks like it runs though and I get the following after a few moments

/...../
/INFO: continuous.c(371): /usr/local/bin/pocketsphinx_continuous COMPILED ON: Apr 25 2013, AT: 22:43:52/
/READY..../

Brandon,

This is very good.  This means that everything is installed properly.  This is how I debug the installation myself.
I typically do this while misterhouse is running, but with the pocketsphinx_control.pl temporarily disabled
to avoid two running at the same time.

Did you quit this manual version before running mhl?
Yes I did quit the running instance before trying mhl. 


However when I try and run ./mhl I get the following error in pocketsphinx_default.stderr

/Error opening audio device default for capture: Connection refused/
/FATAL_ERROR: "continuous.c", line 246: Failed to open audio device/
/
/

Are you running misterhouse as a different user than the user you used to run it manually?
Is your mhl script setup with an su to not run as root?
I haven't modified my mhl script. I tried running rings as both root, and my non privileged user to no avail. 


Its strange that it runs as a standalone, but I suspect that there is something not working with pulseaudio <--> pocketsphinx and have spent the morning trying to troubleshoot that. Any ideas?


I think you have a permission issue with the user. If you are using some other user
to run misterhouse, you need to add that user to to the pulse group.
I actually tried adding my user to the pulse group to no avail. 
brandon@host:~$ groups brandon
brandon : brandon adm dialout cdrom sudo audio dip plugdev sambashare lpadmin mythtv libvirtd pulse pulse-access

Pulseaudio can be a pain sometimes.
I see that now. I am going to try more things and post back here if I ever get it working, I figure that more ubuntu 13.x users will start to see the same problem since they have moved everything to pulseaudio now. 
Thank you for your help, you have been awesome! I can get you ssh access to this box if you wanna try to bang on it. I will just keep trying stuff for now :) 

Jim


------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
________________________________________________________
To unsubscribe from this list, go to: http://sourceforge.net/mail/?group_id=1365