Language translation.

Help
sargon78
2011-09-08
2017-01-03
  • sargon78

    sargon78 - 2011-09-08

    Hi,

    I have just installed MiniDlna on an ARM based computer. Everything works well except I get all messages on my Bravia KDL40W5500 in english.
    Looking at the Minidlna source code, I have seen that other languages were available.
    Searching for the answer with Google, I have found people talking about "Frontview". Is it a TV option ?
    How is it possible to trigger the use of another language ?
    Does it make sense to add an option in the Minidlna configuration file to set the language or is there another option ?

    Regards.

     
  • Justin Maggard

    Justin Maggard - 2011-09-17

    Frontview is the web management console for ReadyNAS.  If you're not using a ReadyNAS, you'll have to create the localization files using msgfmt, and manually install them in the appropriate directory (usually something like usr/share/locale/).

     
  • sargon78

    sargon78 - 2011-09-19

    Hi,

    I finally got it working thanks to your reply.
    I ran "dpkg-reconfigure locale" and installed my locale (fr_FR.UTF-8).
    I went to the directory "po" coming from the initial tar file and executed "msgfmt fr.po -o minidlna.mo".
    I moved the resulting file into /usr/share/locale/fr/LC_MESSAGES.
    Then, I added the line "export LC_MESSAGES=fr_FR" in the /etc/init.d/minidlna file.

    Regards.

     
  • NeoCrazydoub

    NeoCrazydoub - 2016-11-04

    HI, i tried sargon78 method, all wend good but my dlna 1.1.5 is still in english, i don't understand!
    Could someone help me?

     
  • Shrimpkin

    Shrimpkin - 2016-11-05

    Make sure your locales are set properly. Rebuild your database with '-R' after any locale changes.

     
  • NeoCrazydoub

    NeoCrazydoub - 2016-11-10

    Thanks for answer...
    Locales are set properly... I double-checked everything and there's no problem.
    It's for a raspberry server under Jessie... Is it a problem?
    -R is for /etc/init.d/minidlna? in this case it doesn't work...

     
  • Shrimpkin

    Shrimpkin - 2016-11-23

    You should run the program and not the init script. If you are using a recent version, add grep locale to see which locale is being used.

    /etc/init.d/minidlna stop
    minidlna -d -v -R -f /path/to/minidlna.conf | grep locale
    
     
  • NeoCrazydoub

    NeoCrazydoub - 2016-12-18

    Thanks for answer, unfortunately, when i use command:

    minidlna -d -v -R -f /path/to/minidlna.conf | grep locale`
    

    It tells me that command doesn't exists!

    ` -bash: minidlna : commande introuvable`
    

    I tried:

    sudo minidlnad -d -v -R -f /etc/minidlna.conf | grep locale
    

    But console doesn't give me any answer and there's nothing in log!

     
    Last edit: NeoCrazydoub 2016-12-25
  • NeoCrazydoub

    NeoCrazydoub - 2016-12-27

    No Idea? :D

     
  • Shrimpkin

    Shrimpkin - 2017-01-03

    Use a recent version of minidlna >= 1.1.6 (currently only available in git). It will have locale debugging.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks