errors on first run after set-up on Mint 14

  • watty62

    watty62 - 2013-01-26


    I've installed minidlna on Linux Mint 14.

    When I run the command:

    sudo service minidlna start

    I get the following errors:

    getifaddr.c:73: error: ioctl(s, SIOCGIFADDR, …): No such device
    minidlna.c:474: error: Media directory "/media/HardDrive/music    # Use A, P, and V to restrict media 'type' in directory" not accessible!
    utils.c:265: warn: make_dir: cannot create directory '/var/cache/minidlna      # Needs to be un-commented']
    minidlna.c:529: fatal: Database path not accessible!

    Can anyone point me to where I can get more info to rectify the problems causing these errors please?

    The location of my media is an external hard drive which is mounted on boot as


    I've checked and the path to that is OK.

    Thanks for any help


  • watty62

    watty62 - 2013-01-26


    I've got rid of the first error by commenting out the line in minidlna.conf:


    It now *only* has the other errors…..


  • watty62

    watty62 - 2013-01-26

    Update 2

    I've now looked into this more - looking at other forums,

    The media directory issue is an odd one.

    The location of my media is an external hard drive which is mounted on boot as /media/HardDrive/ I've checked and the path to that is OK.
    so the config line for Audio is
    media_dir=A, /media/HardDrive/Music

    and it returns the error above.

    I ran
    chmod -R 755 /media/HardDrive to make sure permissions were ok - but still no joy.

    I changed the audio direct line to

    media_dir=A, /home/Watty/Music but that returned the same error.

    If I comment out the line
    media_dir=A , ……etc altogether

    then it doesn't choke on subsequent lines
    media_dir=P, /media/HardDrive/pictures

    media_dir=V, /media/HardDrive/video

    which is odd.

    Lastly I haven't yet looked at the final error but appears to have a permissions issue in making or writing to
    yet it does exist.

    Thanks for any pointers!

    Thanks for any help Watty

  • Craig Chambers

    Craig Chambers - 2013-01-28

    I had an issue like this with the cache location once on my mother-in-law's Netgear Stora…

    I fixed it by setting the cache location in the config file.  (Did you uncomment it, like the debug statement suggests?)
    If that fails, make sure that the location has the correct access permissions for the user that runs the minidlna service.

    Not wanting to state the obvious, but looking at your paths, you have a capital M on 'Music' but not on the video and pictures folders… Is it really a capital on that folder? 



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks