Media File Permissions

  • Tom Balaban

    Tom Balaban - 2013-02-07

    Sorry if sound grumpy but I just wrote a lengthy post of my problems with miniDLNA after getting to work properly yesterday.

    Actually miniDLNA was very easy to set up and get running but to satisfy another need I changed the permissions on my media drive from 777 to 755. From that point on I could see my files nut could not play any of them. I tried adding 'nobody' to my 'users' group. No Joy. I then created a new user 'minidlna', set 'minidlna' as miniDLNA's owner, added 'minidlna' to my 'users' group and still no joy.

    At this point I should tell you the the 'users' group is the group on the media drive.

    So I completely removed miniDLNA and reinstalled it. Copied over my minidlna.conf which was unchanged from when things were working great and started minDLNA.

    Now it consistently fails with a message that "PID 4622 read from file /var/run/minidlna/ does not exist." the it fails.

    Any suggestions/help will really be appreciated.

  • Cecil Coupe

    Cecil Coupe - 2013-02-07

    I know the pain.  Is Samba serving the same files/directories? If so, you have play by Sambas defaults or (shudder) configure Samba differently.  I did a chown -R nobody.nogroup on the media dirs and then a chmod -R 777.  Not smart if you let hackers onto your home network. Minidlna just reads the media files. My minidlna starts up at boot and runs as root so no user/group fiddling for it.  It sounds like your experiements with users/group files and minidlna owner have not been completely undone. Get rid of the excess groups & users and if Samba is involved, take a deep breath & relax.

  • Tom Balaban

    Tom Balaban - 2013-02-07

    Thanks for the sympathy. :-))

    I resolved the problem the easiest way possible. by starting from scratch. It took about 3 hours but the Pogoplug is now running Samba, miniDLNA and ProFTP. The only issue I want to deal with is restricting the FTP users from writing/erasing my media files. I\'m sure there\'s a way to do that in ProFTP\'s conf file. I may not want to take too much time for that since I\'ll eventually install OwnCloud and make the media available that way.

    Consider this thread closed. I did try to post my fairly complete set up instructions for other lost souls but the forum server decided it was SPAM and prohibited posting. I'll find some where else to post it/

  • Tom Balaban

    Tom Balaban - 2013-02-07

    After a bit of reading I have managed to make my media files read-only for every one but me in ProFTP.

    All I had to do was add these 5 lines:
    <Directory {path to media files}>
       <Limit WRITE>
          AllowUser {my user name}


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks