SourceForge has been redesigned. Learn more.
Close

[v.1.1.3] Samsung TV (C6xxx) rewind/fast-forward issue (aka: Samsung patching madness)

Help
QmQ
2014-07-30
2014-08-21
  • QmQ

    QmQ - 2014-07-30

    Hi,

    For the past 3-4 years I've been using miniDLNA on my OpenWRT router and all worked perfectly with my Samsung UE46C6720 (4-5 years old I think). I do remember that after I first installed miniDLNA streaming of movies worked OK. I don't know about subtitles. But I do remember problems with rewind/fast-forward not working. And I do remember doing SOMETHING to fix this... And I do remember that after doing so I had a satisfactory result: could play movies with subtitles and rew/ff them OR jump-to a specific moment in the movie (with thumbnails). So I stopped playing and started using :) And I never upgraded until now...

    Now I got a new TV (Panasonic VT60 plasma) plus the router died so had to re-setup the entire media ecosystem at home. I used an old laptop (P4 ~2GHz, 1GB RAM) with Ubuntu Server 14.04 LTS. I had to build miniDLNA from source (v.1.1.3) since the one from the repository segfaulted.
    So I got the sources, built it, setup minidlna.conf, run, watched with htop until it stops scanning the library. And later I checked with the Panasonic and all was fine: streaming 1080p MKV, rewind/fast-forward and jumping to a specific moment of the movie. I was happy :)

    But the Samsung remains as a second TV and how shocked I was when I discovered that 1080p MKVs play OK with subtitles [UTF-8, CRLF, ".srt"], BUT rewind/fast-forward does not work! Bookmarking works OK (I get the 'press D to continue watching' message). I expected all those patches to be in the newest version after 3-4 years but apparently they're not. So I came here, read the entire 7-paged thread on patching and became confused...

    Many issues addressed first by separate patches, later by big patches and even later again split into smaller patches. All for old versions of miniDLNA.

    So:
    1. Can anyone somehow clarify which patches must (and can) be applied to 1.1.3 to just have rewind/fast-forward?
    2. Also the 'jump to moment in time' feature would be nice (the one activated by the OK button while playing). It displayed a few thumbnails at some points in the movies time and allowed to jump straight there. I don't actually need the thumbnails - I just want to be able to jump.
    3. Justin: why weren't those patches integrated? I read your comment saying that you didn't like them as they had many bugs and were too big. Is that the case?

    By the way:
    I don't want/need to have movie thumbnails while browsing files nor any other features.
    I just don't like spending 20 minutes of 10-second-jumping forward to simply continue watching a movie from a certain point (happens often when I start watching on Panasonic and later want to continue on Samsung).

    Thanks!

     
  • QmQ

    QmQ - 2014-08-21

    I've done some testing, browsed through the code, etc.
    From what I understand MTA files are necessary for Samsung TVs to display chapters, but the token "mta" does not appear in the source code...

    Was this removed from the code and simply should not work?
    No idea about ff/rew - works from USB, not from DLNA.

     

Log in to post a comment.