Windows Mediaplayer causes minidlna to crash

  • SilverOne

    SilverOne - 2012-05-20


    - Installed minidlna with pkg_add on freebsd 9. (says its Version 1.0.22)
    - Edited the minidlna.conf

    …so far so good, but if i try to start it, it ends itself in a split second. No output was given on the console.
    If i look at the minidlna.log it contains only 2 lines, one with warn: starting minidlna… and one with warning: HTTP listening…

    This stiuation was totally sucking my balls!!
    Why no error message ??

    Already wanted to give up than i saw a post of someone who launched it with the -d option, so i finally got some usefull output.
    I saw that clients tried to connect and it crashed at some point for the windwos media player.
    Last 2 lines of the output was like:
    - upnpevents.c: debug: addSubscriber(….
    - segmentation fault
    So i killed the windows media player process with the taskmanager (didnt had any windows open).
    And yeehaaa minidlna finally keept alive and i could even play a movie on my TV without crashing it :)

    - Windows Mediaplayer: Version 12.0.7601.17514

  • Matthew

    Matthew - 2012-06-16

    I had this same problem, only it was Verizon FIOS cable boxes that caused same error, seems to work ok if i start minidlna when not connected to router just my local switch, then i can plug back in

  • Justin Maggard

    Justin Maggard - 2012-06-19

    If either of you can reproduce a crash with a current version of the code, I'd love to get some more info so we can get it fixed.

  • hal9000

    hal9000 - 2012-08-07

    I can confirm this bug. Every time I turn on Windows machine in my local network minidlna (running in FreeNAS jail) crashes. I have to kill Mediaplayer on Windows and restart minidlna every time.

  • Chris

    Chris - 2012-08-11

    Hi All,

    New to DLNA - For the last few years ive been streaming to my (rooted) Samsung C series via SMB.  Ive just got a new server to upgrade my ReadyNAS Duo, and i want to run freeBSD on it to take advantage of zfs.

    I have ran Minidlna V1.0.22 on FreeBSD 9, and can also confirm the crashing upon Windows media player connecting to it.

    On my ReadNAS it is supplied with Minidlna (V1.0.24.5 ) and i dont observe the issue; it seems to work fine on my Samsung C series, LG, + multiple android devices.

    I have been trying to compile V1.0.25 for freeBSD 9 without luck so far (well having appropriate knowledge would make up for the need for luck!).  It would be great if some clever has managed to do this to post their binaries :)

  • Chris

    Chris - 2012-08-12

    After a lot of pain and suffering I gave up trying to compile 1.0.25 on FreeBSD 9….  as i gave up i stumbled across 1.0.24 port:

    "Download this directory in Tarball"

    Extract  (i put it in /usr/ports/net/minidlna, moving the 1.0.22 version)

    make install clean  (received error… followed instructions to de and re install)

    Configured .conf file.

    Testing as we speak.  No issues with Windows media player….

    If only i checked for new ports 3 days ago!!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks