MKV on Samsung Galaxy S

Help
Dave
2010-09-28
2013-05-29
  • Dave

    Dave - 2010-09-28

    I am trying to get MKV files working on my Samsung Galaxy S (which uses AllShare).  I also have a Samsung TV.

    All file formats work on the TV (avi, mkv, etc)
    All files formats EXCEPT mkv work on the Samsung Galaxy S (avi files work fine)
    If I put the mkv file onto the Galaxy S itself, it plays fine.
    If I attempt to play an mkv file from the minidlna server, I get an "Unsupported File Format" error.

    The last bit of log when i try is here:

    [2010/09/28 19:47:31] upnphttp.c:1659: info: Serving DetailID: 20 [/path/to/file.mkv]
    [2010/09/28 19:47:31] upnphttp.c:1075: debug: sendfile error :: error no. 32 [Broken pipe]
    [2010/09/28 19:47:31] minidlna.c:1003: debug: HTTP connection from 192.168.1.16:57057
    [2010/09/28 19:47:31] upnphttp.c:224: debug: Range Start-End: 2424832 - 2686975
    [2010/09/28 19:47:31] upnphttp.c:116: debug: Client found in cache. [type 3/entry 1]
    [2010/09/28 19:47:31] upnphttp.c:707: debug: HTTP REQUEST: GET http://192.168.1.11:8200/MediaItems/20.mkv HTTP/1.1
    Accept: */*
    Host: 192.168.1.11:8200
    Range: bytes=2424832-2686975
    x-wap-profile: 
    User-Agent: Samsung Player User-Agent
    Connection: Keep-Alive
    [2010/09/28 19:47:31] upnphttp.c:1659: info: Serving DetailID: 20 [/path/to/file.mkv]
    

    Advice would be appreciated.  I am running the latest version (1.0.18) on openSUSE 11.3 (64bit).

    I tried adding "Samsung Player User" to the list of agents in upnphttp.c in the same style as what is in there, but with no change.

    Thanks in advance,

    Dave

     
  • Dave

    Dave - 2010-10-04

    Might there be any additional information I can provide that might help resolve this?

    Thanks again in advance.

     
  • DerGrinch

    DerGrinch - 2010-10-04

    Hey abricorn,

    Samsung TVs (and maybe also the galaxy s?) expect a "wrong" mime-type of "x-mkv" for mkv-videos, and so there is a "model-switch" in the source (search for x-mkv in upnphttp.c). I don't know if this model-switch is also working for the galaxy S. If you only have samsung-clients (samsung TV, samsung mobile) and do not use minidlna with any other devices, you may try to comment out this switch, so that everytime the "wrong" mime-type is sended.

    Search for x-mkv in the upnphttp.c as I told you above, you'll see the following lines:
    http://cxg.de/_93f677.htm
    Now comment the if out, so that these lines look like:
    http://cxg.de/_c7c490.htm

    If there are no delivery problems, I hope that I get my Galaxy S in a week or two. Then I may have a closer look on it and may try to implement a better model-switch (Although I'm not a C-developer or so)

     
  • Dave

    Dave - 2010-10-04

    dergrinch,

    I really appreciate the idea and response.  I have it a shot, but no luck.  It still worked fine on the TV, but still gave the same error on my Galaxy S.

    I look forward to some new possibilities when you have a Galaxy S in hand.  :)

     
  • carl alva

    carl alva - 2010-10-08

    Aunsoft Video Converter helps you convert between various formats. It is the must-have conversion tool for video lovers, and enables you to enjoy movies on computer, to further edit video for creation, to present video on HDTV, and to publish video online in web-friendly format. You can control your video and music on popular portable devices including iPad, Nexus One, HTC Hero, Zune, iPod, PSP, Apple TV, iPhone anytime anywhere.

    With this powerful converter, you can also convert videos for video editing software like Adobe Premiere, Windows Movie Maker, Sony Vegas, and upload video to YouTube and MySpace to share videos.

    http://www.aunsoft.com/video-converter/

     
  • Justin Maggard

    Justin Maggard - 2010-10-08

    Hi abricorn,

    There's one more place that needs special treatment.  From fresh, unmodified source code, open up upnphttp.c.  Then find the line that contains "strncmp(p, "SamsungWiselinkPro", 18)", and change that part to say "strncmp(p, "Samsung", 7)".  If that doesn't work, we may need to look at some more logs.

     
  • Dave

    Dave - 2010-10-08

    Hi jmaggard,

    Thanks for the response.  I wasn't 100% sure if you were saying I should make your change as the only modification to the source or if I should be combining yours with the post#3 change.  So I tried both ways.

    Unfortunately, both styles resulted in the same "Unsupported File Format" error.  It continues to work fine on my SamsungTV through all of these modifications.  And other non-mkv files continue to work on the Galaxy S.

    This may not be something you are in a position to answer… but is it possible that the media player on the Galaxy S could some how have code to disallow MKV via DLNA?  I mean… the MKV files do play if the file is local so it certainly does recognize it.

    I really do appreciate the continued assistance.  As for the log info, is there anything other than putting it in debug mode that I need to do?  If not, here is the full log:

    http://www.landlordhat.com/stuff/log.txt

    Thanks again.

     
  • DerGrinch

    DerGrinch - 2011-02-02

    So, no updates on this? My SGS is here, but I forgot this thread. It seems that SGS is even unable to play mkv with Samsung PC Share Manager (see http://www.android-hilfe.de/samsung-galaxy-s/50231-allshare-mkv-dateien.html (German)). So its missing feature in the SGS-AllShare-Software.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks