Help save net neutrality! Learn more.

Sony BDP-S490 new firmware issues

  • Vittorio Calzolari


    after having happily used my new sony player, a model BDP-S490, for a couple of months, last week I have been forced by Sony to make a firmware upgrade (M12.R.MO430) and voila, all MKV and AVI (AVC and DIVX/XVID codecs) stop to be played from my GoFlex Home with MiniDLNA 1.24.
    Looking around in the net, I realized it is a problem related to the control of the MIME type sent by the server, now more strict. In post #5 of this thread there is an example of a workaround used in another server. Is there any chance to have the workaround applied on MiniDLNA? I tried myself but this is beyond my possibilites..



  • Vittorio Calzolari


    just a little update: the new firmware for the BDP-Sx90 is not more compatible with DIVX container. To play DIVX a change of the FourCC to xvid/XVID is needed. Therefore, talking about MKV, the workaround used by miniDLNA, which fools the renderer changing the MIME type, is not working anymore.
    This post in AVS forum explains it better than me.
    Since the player now accepts the MIME types "x-matroska" and  "avi", I think that a patch to upnphttp.c file to remove the workaround should be enough, but I am not sure.
    Any suggestion about any other modification required?

    Thank you,


  • crees

    crees - 2013-01-01

    Hey Vittorio,

    I hope you haven't given up while waiting; I've discovered a nice workaround in upnpsoap.c; simply removing the exception for the SonyBDP case fixes playback for me.  I'll work on something more elegant based on versions when I can, but until then the patch at  should hopefully help you out.


  • Vittorio Calzolari

    Hi Chris,

    thanks for the hint.
    I have given up because I am not able to compile MiniDLNA anymore on my Seaagate Goflex Home.
    I managed to compile it until version 1.20, but now I got so many error messages, even afters having updated all the required headers and libraries ( but I am not a Linux expert).
    I hope to find somebody who have compiled with the work around for my device.

    Thank you, happy new Year!!


  • DACB

    DACB - 2013-01-14

    That patch worked for me.  I also commented out a similar section in upnphttp.c, but that probably wasn't necessary.

  • Mark the Red

    Mark the Red - 2013-01-20

    Just bought a Sony- bdp-s790 blue ray player.   My current "server" is a HDD attached to my Asus RT-n66u router running the miniDLNA / Samba server.   

    I cannot stream anything from this dlna server to my bdp-s790 as it keeps saying "format not supported"

    I can stream these files to my Samsung pn59d8000 TV, tablet, etc. no problem.   But my Sony bdp-s790 no dice.   If I put these files on my PC running Serviio it streams to the s790 no problem..

    Long story short, there is some kind of hoop the miniDLNA is not jumping through for the s790 that it does just fine for all other DLNA clients (i.e., my tablet, phone, etc. etc.)  It seems to be the MIME settings of the DLNA

    Are there any miniDLNA clients such as dd-wrt , tomato, etc. etc. that can somehow circumvent this?

    Appreciate the help in advance…

  • Mark the Red

    Mark the Red - 2013-01-20

    Appreciate the response.  Checked the code on the router minidlna firmware that I  am using here and it appears to be identical to the patch above;

    Must be something else causing this problem.  Good ol' Sony: "Hey lets do something completely different from all the other DLNA clients in the world with our flagship BD player!!!!"

  • crees

    crees - 2013-01-21

    No.  The only common factor is that it touches the same file.

    Older Sony devices required that media be marked as DivX.  Modern Sony devices don't support DivX to save money, hence the breakage.

    Try the patch, it works.

  • Mark the Red

    Mark the Red - 2013-01-22

    Sure does!  Thanks guys.  You are most helpful!

  • Kevin

    Kevin - 2013-03-02

    Thank you very much utisoft! This patch works very great with my Sony BDV N990W !

  • ChrisO

    ChrisO - 2013-03-04


    I have this exact same issue on my ReadyNAS NV+ V2 when trying to play to a SONY BDPS390 . I have SSH access to the NAS and would like to apply this fix, but am unsure how to. If it boils down to manually editing the file, so be it, but I would very much appreciate some guidance on how to make this change.

    Thanks a lot

  • mohsen57

    mohsen57 - 2013-03-24


    I recently got a sony n990w,
    and i am streaming media from tplink wdr4300 with openwrt firmware,
    i have this bad problem with this sony bd player, which is cant play mkv files, i have samsung bd player and it is fine and no problem playinh anything via streaming.
    actually first time when i started sony bd player, it show content of streamed hdd as true mkv like this (*video.mkv) it have star on most video files.
    but after just little working, evry file turn to mpeg, and stay as it all the time, and player cant p[lay it and only say the file is corrupt or not supported,
    i know my files are fine, i can stream it via pc to player no problem at all,
    i read here to use that above patch. but i just know a little about this minidlna things, i just can install and edit those cfg files with winscp and putty only , and configure , and nothing else.
    i have download the source minidlna from this site, and i see those upnpsoap.c and others,
    but i dont know how to patch that diff file, how with what program, dont know what to do, please someone help me,
    please somone help me, and teach me step by step how to patch that minidlna-fix-sony-bdp-sx90.diff to minidlna and use it, please ..
    if anyone can patch it already for me and let me download the main minidlna and just install it i would so much appreciated. thanks

  • Zaim

    Zaim - 2013-05-03

    I have the exact same problem with my BDP-S490, MKV is fine via USB but through my Netgear NV+ V2 the files show up as MPEG and don't play.

    Can't the dlna patch be made so I can just apply it on the NAS ?

  • Justin Maggard

    Justin Maggard - 2013-05-06

    Anybody with an NV+ v2, can you try the addon package here?

  • Manuel Calavera

    Manuel Calavera - 2013-09-17


    I am using FreeNAS with the miniDLNA 1.0.25-1 plugin. I have this problem with the Sony S-490 not being able to play my files (telling me they are corrupt) but I don't know how to apply the given patch. I have searched for the upnpsoap.c file on the miniDLNA dir but haven't found it.

    Can someone help me to apply this patch?


  • FourPlay26

    FourPlay26 - 2014-08-09

    Can I please have some guidance on how to apply this patch.
    Running Windows 7 have GIT Bash installed
    Searched everywhere but unable to locate how to apply
    Thanks in advance

    Last edit: FourPlay26 2014-08-09

Log in to post a comment.