minidlna scanning crash on mastroska read error

Help
2013-09-26
2013-09-27
  • ADreNaLiNe-DJ

    ADreNaLiNe-DJ - 2013-09-26

    Hello,

    I run minidlna 1.1.0 on a ReadyNAS NV+ (sparc).
    When I run a rebuild of the db, i face a crash during the scan on a MKV file.
    Here is what the log said (when minidlna is launched on debug mode):

    [matroska @ 0x20158248]Read error at pos. 135 (0x87)
    [matroska @ 0x20158248]Read error at pos. 136 (0x88)

    I've tried to "repair" the file with Meteorite but still same issue.

     
  • ADreNaLiNe-DJ

    ADreNaLiNe-DJ - 2013-09-26

    In fact, i tried to repair the wrong file.
    Now, the file is repaired (remuxed with mkvmerge) and scan is OK.

     
  • Justin Maggard

    Justin Maggard - 2013-09-26

    Any chance I could get a copy of the bad file?

     
  • ADreNaLiNe-DJ

    ADreNaLiNe-DJ - 2013-09-27

    I can send you a copy.
    Just let me know where i can drop it...

    Also, the log file confused me.
    I thought that was the file, appeared above the read error, was faulty.

     

Log in to post a comment.