Unsupported Format (s): video/x-msvideo

  • Anonymous - 2012-07-21


    firstly a big thank you and thanks to the project, I donated to you a few years back and have been using you ever since. Also thanks to anyone who's willing to help me on this, I can see there's high demand. I have the patience and some Linux know how but where this is concerned is beyond me.

    My problem is identified I think…

    I'm was using Minidlna server to stream videos to my phone (and worked great over WAN) which I recently sold to buy a Galaxy Tab2.

    Attempting to stream .AVI and .MKV the device is reporting 'Unsupported Format(s): video/x-msvideo' & 'video/x-matroska' respectively.

    I've used my Google Foo to the best of my ability tonight and found a possible clue. Something about MIME types?

    Anyway if anyone knows how I can get Vids working on this Tab2 I'd be willing to sell my soul to you. I'd be greatful if anyone doesn't recommend another server, unless it's also a CLI / non GUI type as I'm running on a headless 600Mhz box.

    Thanks and all the best.

  • BT

    BT - 2012-07-22

    What UPnP/DLNA application are you using on your device to access MiniDLNA?

  • Anonymous - 2012-07-22


    It's working ok for AVIs from a Sony Ericsson SK17i.

    However on the Tab2 7" it's not playing ball.

  • BT

    BT - 2012-07-23

    Did you use the same video playback application on both devices? If you're using the default video playback application that came with the Tab2, it probably doesn't like the mimetype it receives from MiniDLNA. I own a Samsung DLNA TV and it won't play MKV's unless the mimetype is set to video/mpeg. So this might this be a common issues with Samsung UPnP/DLNA devices.

    I personally use MiniDLNA along with BubbleUPnP and MX Player on my Android devices and have no issues with any video type. Additionally BubbleUPnP does have an option to disable mimetype checking so this might be helpful.

    Alternatively you could try MediaTomb UPnP media server. It's CLI based with a web interface. MediaTomb is very configurable and you can specify the mimetype to send for each type of file. The only issue with MediaTomb is that it hasn't been actively developed for almost 2 years so you might have difficulties getting support.

  • Anonymous - 2012-07-23

    hi amak79, yes I use UPnPlay with MXPlayer (<3 MXPlayer),

    (NB: Why would htings just start working because i installed it on Ubuntu?)

    i'm not too keep on switching just yet, certainly to a dated warez like mediatomb, but thank you I'll keep it in mind as a last resort.

    whilst hunting google and waiting for your response i installed ubuntu 12.04 onto the same media box and tried minidlna on it.


    both devices play via minidlna on ubuntu and the samsung is even capable of using hardware decoding, where as before both were using (Fast) software decode.

    on the basis the media server isn't running anything except a proxy, rtorrent and minidlna i'm going to switch it over from debian to ubuntu, as i both have nothing against ubuntu and due to the nature of what this is i just want it working minimal fuss.

    i feel some responsibility to other future thread readers to continue down the debian route incase they need answers, unfortunately i have none for them. but I would hazard a guess that mediatomb would be a good start RE: MIMEtypes

    thanks, amak79, i will now begin testing this on ubuntu.

  • BT

    BT - 2012-07-23

    I'm not sure why it works in Ubuntu and not Debian. I don't use either. Maybe they have different versions. Newer versions could certainly have fixed or added support for your device. This was the case with older versions of MiniDLNA and my TV.

    Regarding MediaTomb, It's defiantly not warez. It's great open source software who's developers currently have no time to develop it. I still have it installed and occasionally use it with my PS3 as it can do on the fly transcoding.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks