Issue on ntfs-3g mount

Help
Ric
2010-11-21
2013-05-29
  • Ric

    Ric - 2010-11-21

    This is part of the log:

    upnphttp.c:1657: info: Serving DetailID: 91
    minidlna.c:1003: debug: HTTP connection from 192.168.0.2:48953
    upnphttp.c:224: debug: Range Start-End: 4308992 - 4440064
    upnphttp.c:707: debug: HTTP REQUEST: GET /MediaItems/91.mp3 HTTP/1.1
    HOST: 192.168.0.1:8200
    Range: bytes=4308992-4440064
    DATE: Sun, 21 Nov 2010 20:38:36 GMT
    CONNECTION: close
    USER-AGENT: Linux/2.6.27.13, UPnP/1.0, Portable SDK for UPnP devices/1.6.6

    upnphttp.c:1657: info: Serving DetailID: 91
    minidlna.c:1003: debug: HTTP connection from 192.168.0.2:48954
    upnphttp.c:224: debug: Range Start-End: 0 - 16384
    upnphttp.c:707: debug: HTTP REQUEST: GET /MediaItems/75.mp3 HTTP/1.1
    HOST: 192.168.0.1:8200
    Range: bytes=0-16384
    DATE: Sun, 21 Nov 2010 20:39:02 GMT
    CONNECTION: close
    USER-AGENT: Linux/2.6.27.13, UPnP/1.0, Portable SDK for UPnP devices/1.6.6

    upnphttp.c:1657: info: Serving DetailID: 75
    upnphttp.c:1075: debug: sendfile error :: error no. 22
    minidlna.c:1003: debug: HTTP connection from 192.168.0.2:48955
    upnphttp.c:224: debug: Range Start-End: 0 - 4096
    upnphttp.c:707: debug: HTTP REQUEST: GET /MediaItems/75.mp3 HTTP/1.1
    HOST: 192.168.0.1:8200
    Range: bytes=0-4096
    DATE: Sun, 21 Nov 2010 20:39:02 GMT
    CONNECTION: close
    USER-AGENT: Linux/2.6.27.13, UPnP/1.0, Portable SDK for UPnP devices/1.6.6

    upnphttp.c:1657: info: Serving DetailID: 75
    upnphttp.c:1075: debug: sendfile error :: error no. 22

    As you see, the same file is on both directory. T_drive is ntfs-3g partition, USB_Storage is a Fat32 partition.
    I'm in a uClibc environment. T_drive is a soft link to the location of the real mount.
    Both file can be accessed and played using Samba.

    Thanks

     
  • Ric

    Ric - 2010-11-22

    It's not a matter of softlink. Launching minmidlna directly on mount poin has the same isssue:

    upnphttp.c:1657: info: Serving DetailID: 93
    upnphttp.c:1075: debug: sendfile error :: error no. 22

     
  • Ric

    Ric - 2010-11-23

    It was a strange bug in sendfile function. It works fine disabling sendfile ( int try_sendfile = 0; ).

     
  • Justin Maggard

    Justin Maggard - 2010-11-24

    Thanks for the info.  It should be fixed in the latest CVS code.  With FUSE, errno appears to get set to a different value than what I'd seen previously with an smb mount, so it wasn't falling back to regular I/O.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks