MiniDLNA on Samsung C650

Lord LEX
<< < 1 2 3 4 .. 7 > >> (Page 2 of 7)
  • Justin Maggard

    Justin Maggard - 2010-08-27

    Looking at the wireshark capture may help.  But sometimes it's not all that easy to figure out what header or data is cause the change in behavior.  But it's worth a shot anyway.

  • Anonymous - 2010-08-28

    Dear miniDLNA users,

    I managed to get the subtitles working… I forget to rebuild minidlna database I guessed…
    So I've got subtitles, thumbnails for videos (using a patch) : a huge progress !
    Thanks for your help.


  • RandomCore

    RandomCore - 2010-09-04

    Hi 40C650 owners,

    There is a patch extending the minidlna v1.0.18 to add

      - automatic movie thumbnails
      - the subtitle submenu shows up on the TV
      - chapters marker menu is provided (5 points in equal distance: 16%, 32%, 48%, 64%, 80% of complete movie)
      - Samsung PCShare Manager look on the TV
      - Bookmarks (last time point you stopped watching)
      - a more sophisticated init.d script for Debian/ubuntu users

    It is early beta (not everything will work). Here are the bugs I know of:

      - changing the Sorting (blue "D" button on remote to anything other than "basic"/first option will FAIL)

    If you still not afraid of this: You have to rebuild (option "-R") the database because it changed for the bookmarks! The autothumbnailer is the patch from the forum which will pollute your movie folders with movie.ext.jpg files (I guess this is necessary, because on-the-fly production of 20 thumbnails is far to slow for a usable directory view).

    Enjoy (or mail to me because Justin doesn't have anything to do with this one yet. Maybe he will in the future incorporate the patch)

    cu, RandomCore

  • Boulange

    Boulange - 2010-09-19

    Dear all,

    I just wanted to add my feedback on RandomCore patch about Samsung C650
    On my own Samnsung PLASMA 50C6500 (lastest firmware T-VALDEUC_2002.0) here are the details :

    1- Automatic movie thumbnails : OK (I even added mp4 and m2ts as the extention file which should create a thumb)

    2- The subtitle submenu shows up on the TV : KO my TV fails to display the subtitle menu and even worse failed to display the subtitles itselves… Maybe the code was too specific for the C650 even if I thought it will be ok with my C6500…

    3- Chapters marker menu is provided : KO my TV is not able to display them and it seems to be a special feature from the C650 TVs… a shame…

    4- Samsung PCShare Manager look on the TV : OK excellent work !

    5- Bookmarks : OK I was looking for this feature with the 'D' key

    So 3 out of 5 for my Samsung TV (the best score will be 4 as I don't think my TV will handle chapters).
    I'll try to send RandomCore the SOAP log from Samsung PC Share Manager to my 50C6500 Tv to see the problem about subtitles syntax.

    Keep working RandomCore, congratulations and thanks for sharing.

  • RandomCore

    RandomCore - 2010-09-22

    Hi Fr3d,

    thanks for trying the patch.

    I tested it (and wrote it for) a LE40C650 with firmware revision 1013. If some features don't work there are actually two possibilities:

    a) It simply doesn't work like it would on my TV
    b) It is not implemented in your TV

    So, to narrow it down, you would've to test it using the PCShareManager and have a wireshark (or similar tool) running while testing.

    I found, that some features (chapters, Bookmark continuing) are actually driven by the first XML Message (upnpdescgen.c, struct rootDescSamsung). So maybe there's another difference for your TV.

    It would help, if you did a network dump (and then removed most of the video contents :-) ) and post it here while

    a) Turn on TV
    b) Wait 10s to have the TV paired with the PCShareManager
    c) Start Media Player, choose first movie with subtitles
    d) Stop movie after 5s
    e) Leave Media Player
    f) Turn off TV

    Remember not to do too much in one dump file! I used Wireshark on the Windows machine to grab, then to get rid of the data contents (I leave just the first 5 to 10 packets), then go to my Linux box and run it through

    for i in $(seq 0 144); do echo "- Stream $i -";tshark -r samsung.pcap -w - "$i"|tcpflow -eCr -;done > samsung.txt

    to get some useful textual representation.

    I have used my patch for 3 weeks now and have not noticed any ill effects.

    cu, RandomCore

  • Boulange

    Boulange - 2010-09-22

    Dear Randomcore,

    I haven't got tshark on my linux NAS, but I get a 'light' version (compare to the one I send you by email on your sourceforge account) of Wireshark monotoring a unique video file with its subtitles.

    I filtered packets (filters set to my PC's IP and my TV's IP ==> "ip.addr == && ip.addr ==") up to the 1st packet including the first subtitle text.

    You can grab it from this url (les than 600kb) :  HERE.

    Tell me if it's enought…Best regards,

  • RandomCore

    RandomCore - 2010-09-23

    Hi Fr3d,

    I think I got a lead on why your chapters aren't there.

    In your pcap I see the renderer ask for sec:MetaFileInfo (in Filter tag):

    -- Stream 12 --
    POST /upnp/control/ContentDirectory1 HTTP/1.0
    CONTENT-TYPE: text/xml;charset="utf-8"
    SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
    <s:Envelope xmlns:s="" s:encodingStyle="">
    <u:Browse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1">
    <Filter>@id,@parentID,@restricted,dc:title,upnp:class,res,dc:date,@childCount,sec:CaptionInfo,sec:CaptionInfoEx, sec:dcmInfo, sec:MetaFileInfo,res@resolution,res@size,upnp:genre,dc:date,upnp:album,res@duration,upnp:albumArtURI,res@bitrate,dc:creator</Filter>

    but it is not delivered by your share manager.

    There should be a line like

    <sec:MetaFileInfo sec:type="mta"></sec:MetaFileInfo>

    in the answer, but it isn't. This line (on my LE40C650, Firmware 1013) leads to a request for the MTA file, which has embedded 5 nice base64-encoded thumbs and each a VideoLocator resources stating the seconds from movie start.

    Do you see chapters when using the Smasung PCShareManager? If so, the device seems to do it by itself.

    Having glanced over the rest: There is not so much difference in the XML there. (Actually it's more or less the same conversation with different filenames). Another difference: My TV asks for some graphics (JPG) after identifying the DLNA server, yours does not.

    Just to ask  the unavoidable: Have you configured your TV into some unusual mode? I can switch sorting (blue remote button labeled 'D'). If I do this, things get really awkward. There may be other (unsupported) options on your TV…

    cu, RandomCore

  • Boulange

    Boulange - 2010-09-23

    Hi randomcore

    My Samsung 50C6500 does NOT support chapters as I did not find a way to display them even using PCShareManager, even with the latest firmware…

    About the displayed mode, nope I use the default one so I don't think it's coming from this end.

    What might be worth a try is to isolate each feature you added in a different patch so I can applied them one at a time and find out which one is messing around.

    Are you able to isolate the a patch for the D button (last bookmark) for exemple ? Another one for the subtitles and a last one for the PCShareManager design ?

    By the way did you create your patch from the 1.0.18 sources tarball or from the CVS ? (I used the source not the cvs). There might be a slight difference which end up by messing with the subtitles…

    Looking forward to your answer.
    Best regards,


  • dohnalradek

    dohnalradek - 2010-09-26

    Hi. Sorry for my studup questin, but Im begginer at this problem. I try to runminiDLNA on my NAS disk Zyxel NSA210. I unpack file minidlna-bookmark.tgz from this discussion. Unpackinf finished ok. I try to run by command sh /ffp/start/ start, but this failure and return me cant load library ''. Where I can find this?

  • Boulange

    Boulange - 2010-09-26

    "" is coming from ffmpeg library. You'll be able to find them around on the web.
    By the way the buiild you are refereing to as been build for DLIN NAS DNS-323 usung fun pack :

    funpck -i minidlna-bookmark.tgz

    . See DNS323 Wiki for more details.
    Best regards,

  • Anonymous - 2010-09-27

    I have the same problems with chapters no showing but in my case chapters have been working until I perfomed an upgrade of the TV firmware (PS50C7000) and/or my version of the PC Share Manager (4.2). I will try your patch this evening to discard a problem with the new PC share Manager, but given the previous posts i´m afraid that the problem will be in the firmware upgrade.

  • dohnalradek

    dohnalradek - 2010-09-27

    Thanks fboulange I instla ffmpeg and some next library and now, miniDLNA start ok. But I want to install patch for Samsung LE40C650 TV, I downloaded file minidlna.samsung_patch20100903_mta from this site, but dont know how to instal it on mys network disk. Can you help me please?

  • Boulange

    Boulange - 2010-09-27

    Hi dohnalradek,

    A little bit a search inside this project and you will have find this post where you can find in notre #3 a link for minidlna using the mentioned patch ( compiled for DLINK DNS-323)

    But as VPX mentioned it is not working for him even if he's got a LE40C650 (the patch was design for this model).
    My build might be not properly done I guess… I used the following command to apply the patch to a minidlan folder (patch and folder at the same tree level)

    patch -p1 < minidlna.samsung_patch20100903_mta

    If randomcore (or anyone else) could confirm the right syntax for patching it will be nice.
    By the way I had to add "-liconv " in the Makefile to get it working…

    See you

    PS Oh dear my last post (#11) contains lots of type/spelling errors… Sorry about that…(can't we edit our posts ?)

  • Boulange

    Boulange - 2010-09-27

    To the PS50C7000 owner :

    Yes it seems it's a feature about the C650.
    I thought it will more or less the same firmware between C650 and C6500 or C7000 but it does not seem to…
    What's weired is I find this in the C650 manual :

    When you use Media Play mode through a network connection, According to functions of the provided server:
    xx The sorting method may vary.
    xx The scene search function may not be supported.
    xx The Play Continuously function, which resumes playing of a video, may not be supported.

    Might have to post to Samsung forum on CNET (there's a guy from Samsung who answers most of the users questions).

    Keep lookin' :)

  • Anonymous - 2010-09-28

    I have tested the patch tonight and the chapters and subtitles menu worked properly. So the problem in my case seems related to the last PC Share Manager that doesn´t generate chapters info anymore

  • dohnalradek

    dohnalradek - 2010-09-28

    Thanks fboulange. I install your minidlna-bookmark.tgz and succesfully config miniDLNA. When I run it, it starts. But nothing share (although I config path to shared folders). In log it show me this: inotify.c:89: inotify_add_watch (i-data/1f390b82/video) . What do I wrong?

  • Boulange

    Boulange - 2010-09-28

    Hi dohnalradek

    inotify help you to listen to shared folders, so it will detect new stuff without having to restat minidlna.
    It is not crucial to minidlna, so if you haven't got anything working you might have other errors…

    The minidlna-bookmark.tgz has been build for DLink DNS-323 NAS using fun-plug.
    This might not suits your own device.

    You'll might look for the logs (/ffp/var/minidlan/minidlna.log in my case) to see if there's something wrong inside.
    Or you might start minidlna in debug mode using a -d option such as :

    /ffp/sbin/minidlna -f /ffp/etc/minidlna.conf -d -R

    -f stands for the config file
    -d stands for debug mode
    -R stands for rebuilding the database.

    Keep me posted.

  • Boulange

    Boulange - 2010-09-29

    Dear all,

    With Smasnug HDTech's help (from CNET Forum), I was able to grab Samsung PC Share Manger V4.1 (US) where you can find the link here : (Source).

    As you can see here my European Plasma TV 50C6500 is able to display the chapters :

    So this is good news : my TV is able to handle chapters such as Randomcore did with his patch.
    And you guys could try it with your own TV model (V4.2 is not displaying chapters anymore !!!)

    Now I have to get his patch working as obviously I was unsucceful (minidlna-bookmark.tgz is not a valid build I guess)… 

    Thanks for your attention :)

  • Boulange

    Boulange - 2010-09-29

    Right I mess with the picture. Here it is (last try I promise)


  • Japers

    Japers - 2010-09-30

    Really great work randomcore and Fr3d/fboulange - I used the compiled file versions posted by Fr3D on the other thread, here is my feedback for a 46C8000 Samsung TV:

    1- Automatic movie thumbnails : OK

    2- Subtitle : No subtitles at all on first version, second version subs work BUT still no sub menu.

    3- Chapters marker menu : Not working - this works fine using PC Share Manager

    4- Samsung PCShare Manager look on the TV : OK

    5- Bookmarks/Resume : OK

    6- MKV support : OK fixed and working on the second (untested on first file)

    I know work is ongoing but if you need any help/testing to get the subtitle submenu and chapter markers working, let me know!

  • DerGrinch

    DerGrinch - 2010-09-30

    Chapters (every 10%) are working for me on UE32C6700 with this patch.
    fblounge, you have to patch the .tgz with the original minidlna-source, ala

    patch -p0 < (patch.file)

    in the source-directory. If this doesn't work ("patch" shouldn't ask you any question, if it does, hit strg+c), try -p1.

  • RandomCore

    RandomCore - 2010-09-30

    Hi japers75,

    I don't know the requirements for the Samsung subtitle menu to appear, so I give you, what I use:

    1) external subtitle file in .srt format
    2) .srt-file needs the exact same basename (this_is_a_movie.avi  needs to work)
    3) Subtitles have to be activated in the TVs menu
    4) The miniDLNA has to have time to adjust any file system change in it's database

    If you've got a network sniffer up and running, you will see GET requests on the .srt file at some point from the TV.

    My 40C650 submenu shows settings for subtitle delay and font size and is started with the extras key on the remote.

    cu, RandomCore

  • Boulange

    Boulange - 2010-09-30

    @ randomcore,

    So far no luck building the minidlna with your patch.
    I've got a the following waring when building :

    Compiling upnpsoap.c
    upnpsoap.c: In function 'callback':
    upnpsoap.c:576: warning: unused variable 'disc'

    Hope it's jsut a true warning…
    I had also to add -liconv to MakeFile (such as your patch added ffmpegthumbnailer to it) as I get a error  about libiconv missing…
    Was it the same for you ?

    @japers75 : build your own minidlna patched as mine seems to be dodgy…

    @ dergrinch : on which devide did you build yours (as yours is working) ?


<< < 1 2 3 4 .. 7 > >> (Page 2 of 7)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks