MiniDLNA server no longer showing up on clien

  • Chris

    Chris - 2011-09-21

    I have had MiniDLNA installed and working on Ubuntu 11.04 64bit for quite awhile.  Now, not sure what changed, it only randomly shows up on the clients (ie: 8player, MediaConnect, MLPlayer for iPod).  I tried simple things like removing and reinstalling MiniDLNA and rescanning the media library.  I tried restarting the computer it is installed on.  If I look in System Monitor 3 instances of MiniDLNA, all of which are sleeping.  I am not sure what to try next.  Any suggestions?

  • Justin Maggard

    Justin Maggard - 2011-09-21

    Sounds like the clients' SSDP M-SEARCH packets aren't making it to your Ubuntu box.  Do you have any other programs binding to port 1900?  You can find out with "netstat -nlp | grep 1900".  I've also seen some home routers that seem to block SSDP multicast traffic in some cases, so you might be running to that.

  • Chris

    Chris - 2011-09-21

    Thank you for the quick reply.

    It appears that no other programs are binding to port 1900. 

    I found a setting in the D-Link DIR-825 router that I have titled: "Enable IPv4 Multicast Streams"  this was disabled, so I enabled it and rebooted the router.  The DLNA server is showing up after I did that, hopefully that was the problem.

  • Chris

    Chris - 2011-09-23

    Unfortunately, that did not resolve the issue.  I restarted the router and then the DLNA server showed up on the clients but it did not last.  So it seems the problem is with the router, but I am not sure where.  It has the latest firmware installed.

  • Takkat

    Takkat - 2012-08-22

    For the records and for people that may come here:

    After days of debugging I found out that only after to disabling (unitck) the "Enable Multicast Streams" option  from Advanced Network -> Advanced settings in the D-Link DIR-825 (Firmware 2.01EU - B1) my Samsung UE40ES6100 TV set recognizes MiniDLNA without disconnects. Obviously the SSDP packets were not transferred otherwise.



Log in to post a comment.