Compiling on WD My World Book Edition II

Joe Smith
  • Joe Smith

    Joe Smith - 2010-10-16

    Hello Everyone,

    sorry for soooo dumb question but I'm complete Linux newbie… :( BUT I SO MUCH NEED to run patched miniDLNA on my Western Digital My World Book Edition II NAS drive to be able to watch MKVs on my Samsung C650. I already patched original sources using RandomCore's Basic Samsung TV xxC650 support v2 - ID: 3084362 ( Problem is that if I want to compile patched sources I'll get:


    ERROR!  Cannot continue.
    The following required libraries are either missing, or are missing development headers:

    libavcodec libavformat libavutil libflac libvorbis libogg libid3tag libexif libjpeg libsqlite3

    make: ***  Error 1

    My NAS has Optware package installer installed (I used it for downloading 'patch' and 'make' tools).
    I realize that sources are dependent on some libraries, so I looked into MAKEFILE and changed CFLAGS paths to point to Optware's Includes:
    -I/opt/include/ffmpeg \
    -I/opt/include/libavutil -I/opt/include/libavcodec -I/opt/include/libavformat \
    -I/opt/include/ffmpeg/libavutil -I/opt/include/ffmpeg/libavcodec -I/opt/include/ffmpeg/libavformat

    but even if I do that I'm still getting same error

    What I did:
    1) downloaded minidlna_1.0.18_src.tar.gz
    2) unpacked it inside the device
    3) patched it by 'patch -p1 < /your/path/to/minidlna.samsung_patch20101009_mta2'
    4) tried to 'make' it -> resulting into error described above

    I would like to ask whether someone can tell me what I'm doing wrong :( Whether I need to download all and proper  dependency libraries and where exactly should I put it so then I'll be able to compile patched miniDLNA on my NAS. Or if there are any other steps to make it working…

    Thanks lot guys! You help is very appreciated!

    I bought C650 with idea of flawless and 'plug-n-play' playing of MKVs from my NAS… but not :(


  • Boulange

    Boulange - 2010-10-16

    HI joe,

    If you've got this warnning about thse librairies :

    libavcodec libavformat libavutil libflac libvorbis libogg libid3tag libexif libjpeg libsqlite3

    it means you have not installed them on your device.
    I would recommand you to install them :

    libavcodec libavformat libavutil = ffmpeg library
    libflac = Flac library
    libvorbis = Vorbis library
    libogg = Ogg library
    libid3tag = id3Tag library
    libexif = exif library
    libjpeg = jpeg library
    libsqlite3 = sqlite3 library

    Your best bet will be WD forum about your NAS. There sould be available package to get them from.
    Try or using the ipkg installer :

    ipkg install xxxxx


    BTW You might need as well a ffmpegthumbnail library to create thumbnails from videos files.



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks