video duration

  • George

    George - 2013-03-11

    On most dvd/blueray players have a info or status button.  When this button is pressed a window is displayed
    that show how far you are into the video and the total duration of the video.  Does anybody know if this information
    is calculated by the player or is a request sent to minidlna.  I've tried to use a network sniffer to see if this is happening.
    But I don't seem to see any requests sent to minidlna. 
    The reason for the question is that my Panasonic dmp-bd87 will sometimes display -:- rather than the time.  It also displays a wrong video length.  But when you browse the files the information displayed has the correct length.
    I think it is a panasonic problem.  I can't seem to get them to discuss the problem.  They want to blame minidlna.

  • Justin Maggard

    Justin Maggard - 2013-03-13

    You are correct, that is done entirely by the player.

  • George

    George - 2013-03-14

    Can you think of a reason that when pthread_create  is called to start start_inotify that control is not returned?  But if you run minidlna with the -d option it does return?

  • Cecil Coupe

    Cecil Coupe - 2013-03-14

    I can think of several reasons. First one is debugging/stepping into threads is not the same as what happens when run w/o a debugger. You really have to think hard about threading if you put a debugger in the mix.

    I would guess that your problem depends on the media format being played and how long you wait until you hit the 'info' button.  Also involved are the cache times on your player (when did you last reset the player, or the server, or rescan the media library). You need a reliable test case with controlled conditions - not easy with DLNA if you have a habit of punching various buttons during testing. Been there, done that.

  • George

    George - 2013-03-14

    ccoupe.  I'm not using a debugger.  The -d option just causes a bunch of print statements.  Which does change the
    timing .  When minidlna is run it creates three processes.  If I run my compiled version of minidlna without the -d option
    the first process hangs.  The other two processes seem to be running correctly when using strace to see what they are doing.
    If I run minidlna with the -d option.  strace shows that the first process is also running.
    As for the info problem it appears to only happen with files that are a little bigger than 4GB.  I don't have the exact size.  But when the file gets about 4.3GB it works.  The problem also occurs with files just over 8GB.  Most of my video is recorded tv shows.  After the commercials are removed a one hour show is about 40 minutes and a two hour show is about 1hour and 26 minutes.  But the size of the file varies from just under 4GB to about 4.4GB.  When the problem does show up the info display will display a value of 1 to about 30 seconds.  On my Dlink DSM-520 if I tell it to jump 15 seconds into a file that it thinks is 30 seconds long I actually jump 20 minutes into the file.
    After jmaggards response I now know that the problem is in the device that is streaming the video not in minidlna.

  • George

    George - 2013-03-14

    Solved the problem.  Reloaded original minidlna-1.0.25 source.  added inotify.h from the inotify-dev-0.1-1.tar.  did a rebuild
    and it now seems to be working.  At least the pthread now returns.  I need to see if the files show up tonight after stripping the commercials.


Log in to post a comment.