Philips TV does not show MKV

Yuri
2012-09-26
2013-11-07
  • Yuri

    Yuri - 2012-09-26

    Philips TV 42PFL6097 does not show mkv files. I tried minidlna 1.0.25 on a router (openwrt firmware) with the attached USB hard drive and a PC with Ubuntu 10.04 LTS. All files matroska give message "File not available". Avi files are shown good. Other DLNA servers (xupnpd, mediatomb, ushare) show mkv files with the router, but after 30 minutes the TV lost the server. DLNA client VLC on the PC shows mkv from minidlna on the router good.
    How can I solve this problem? Thanks for advices.

     
  • R S

    R S - 2012-10-03

    can you do the following:

    stop Minidlna
    Turn Off TV
    Start Minidlna using the -d option
    Start TV and connect
    Try to browse to a folder that has MKV files

    Paste the minidlna debug output here.. Basically we are looking for a line that shows the USER-Agent that the TV is sending minidlna
    Once you have have that you can rebuild it using the same trick as https://sourceforge.net/projects/minidlna/forums/forum/879956/topic/5657566

     
  • Yuri

    Yuri - 2012-10-03

    Paste the minidlna debug output here.. Basically we are looking for a line that shows the USER-Agent that the TV is sending minidlna Once you have have that you can rebuild it using the same trick as https://sourceforge.net/projects/minidlna/forums/forum/879956/topic/5657566

    Thanks for answer. I read and tried it.. I try more than 10 my patches, doesn't work. My DLNA client

    USER-AGENT: Linux2.6/0.0 UPnP/1.0 PhilipsIntelSDK/1.4 DLNADOC/1.50
    

    Log, in which TV try to show mkv here.

     
  • Dobri

    Dobri - 2012-10-31

    I have same problem with MKV and Philips TV. Problematic MKV has DTS audio codec that is not supported on Philips TVs. I work manually recoding MKV files with ffmpeg.

    On Linux I use ffmpeg command:

    ffmpeg-i filename_dts.mkv-acodec ac3-vcodec copy filename_ac3.mkv
    

    View http://d.klwe.info/problem-sa-priikazom-mkv-videa-na-philips-tv/

     
  • Yuri

    Yuri - 2012-10-31

    I have other problem. mediatomb and xupnpd play MKV without problems, but minidlna does not play. There is the bug in minidlna headers, which are transfered MKV.
    If movie hase the DTS sound, TV says "Format audio not supported" and plays it without sound. New TV Philips and others vendors also do not support DTS in any form, including passthrough. Old TV Philips (my old 32PFL7623) support DTS passthrough.

     
  • Dobri

    Dobri - 2012-10-31

    Sorry I'm a little quick and I did not read the whole issue. I have a television 46PFL5507K12 and if I try to play MKV file that has DTS audio codec is simply  do not appear on the television screen.

     
  • Craig Chambers

    Craig Chambers - 2012-12-13

    The format specified by the DLNA_PN assigned by minidlna for that container/audio/video type is not supported by the TV, so it does not display it.  You can try to force minidlna to supply a different DLNA_PN that the TV does support, and see if that allows you to get further, but many TVs simply do not support DTS audio.

    On my Sony TV, some file types that do not appear in the video list will play if supplied with a recognised DLNA_PN (set by altering minidlna's database).  This is not the fault of minidlna, but of the lack of standardisation of DLNA in general.

    I have other files where I have repackaged them to contain an AC3 audio track first, then a DTS one.  This ensures that minidlna serves the file with a recognised DLNA_PN, but allows me to select the DTS track if I play back on a device that supports DTS.

    /Craig

     
  • mhorvatx

    mhorvatx - 2013-01-19

    I have the exact same problem playing mkv files ) as the original author on the Philips 47PFL6097k with minidlna-1.0.25 (these are non-DTS mkv files. Mediatomb, for example, works fine on the same TV without any transcoding (the server is an old G4 mac-mini, so live transcoding is out of the question).

    I was inspecting the debug log, and don't know which is the actual USER-AGENT… It starts with:

    USER-AGENT: Linux2.6/0.0 UPnP/1.0 PhilipsIntelSDK/1.4 DLNADOC/1.50

    But when trying to play an mkv file the http GET request uses:

    User-Agent: Streamium

    So, what modifications are needed in the upnphttp.c file?

    The strange thing is that when the playing an ordinary AVI file, the user-agent does not change. I believe that there is something in the response of minidlna in the mkv case that confuses the TV and it changes its user agent to streamium.

    Right now I am stuck using mediatomb, but would really prefer to switch to minidlna due to support of subtitles (which mediatomb only includes if they are live transcoded into the stream).

    Best,
    Matej

     
  • Dmitri Skok

    Dmitri Skok - 2013-02-20

    Minidlna 1.0.25 has a bug in it. Just replace line 1317, file upnphttp.c, "while( offset < end_offset )" with: "while( offset <= end_offset )".
    This fixed the problem with my 55PFL6007.

     
  • mhorvatx

    mhorvatx - 2013-02-21

    I confirm dskok's solution. It works also with 1.0.24.

    Thanks!!!

    Bets,
    Matej

     
  • Yuri

    Yuri - 2013-03-06

    Finally, I checked the solution from dskok. It works good on minidlna 1.0.25 (Openwrt)! Thanks!

     
  • hmurij

    hmurij - 2013-04-04

    How to edit upnphttp.c ?

     
  • wppvos

    wppvos - 2013-04-26

    Yeah, how do you edit this file. Do you need a local build? How do you get the fixed minidlna installed?
    I have the 55pfl6007 as well, would be nice to have it working. Thanks!

     
  • stephil

    stephil - 2013-11-04

    Hi,
    I purchased a Dlink DNS320LW to serve as uPnP library on my home network that has a PC and 2 Philips TVs attached.
    Stock software is so poor in library management but most important, both TVs disconnects from the uPnP share after 30 minutes streaming.
    I tried TwonkyServer (suggested by Philips) and Mediatomb with no luck of solving this problem so I decided to go for miniDLNA (FFP 0.7) although it does not offer a GUI (AFAIK) and installation was a bit tricky for non-experienced people.
    MiniDLNA offers the chance of changing the parameter "inotify_interval" so that my problem with Philips TVs can be hidden and I happily stream now for hours with no disconnections.
    However, what now struggles me is that the 2 TVs don't behave the same way.
    32PFL5507 (older) browse perfectly and even plays MKV files while 42PDL6907 (more recent) doesn't. It sees the files in the structure but any attempt of playing MKV results in "File not available" on screen message.
    As far as I remember, TwonkyServer was working fine so I believe the TV is ok (or at least capable of such format).
    Is there any trick to let my larger TV playing the same files too?

    Thank you for helping

     
  • noname

    noname - 2013-11-07

    Unless you compile for yourself MiniDLNA with changes in source code, suggested by Dmitri Skok.
    There is another solution, but it needs additional editing. Install MiniDLNA version, which already contains solution above. http://forum.nas-central.org/viewtopic.php?f=249&t=11831 Don't forget to stop minidlna daemon before upgrading.
    This version is for Zyxel NAS'es, but you can easily adjust it for your Dlink too.
    Just edit /ffp/etc/minidlna.conf and specify path to your media content, before starting daemon.

     
    Last edit: noname 2013-11-07
  • stephil

    stephil - 2013-11-07

    Thank you "noname", I will try to upgrade following the instructions on the link indicated, let's see how it works.
    However I'd love to compile the package myself but I'm a bit unexperienced in setting the compile environment for this package.
    Is there any tutorial around?

    Nov.7th 2013 : I could finally upgrade followimg the indicated link instructions and it works fine now - inotify_interval increased to prevent Philips TVs to disconnect and MKVs play anywhere ! THANK YOU !

    Nov.11th 2013 : Not dramatic issue, but I tried connecting to the network an old DVico multimedia HD and it could play most files but not all, e.g. some AVI files were not available
    Cheers

     
    Last edit: stephil 2013-11-11

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks