when adding thumbnails no video plays anymore

  • Emmanuel Touzery


    I tried the latest 1.0.24 on ubuntu 12.04 and everything works out of the box with my samsung TV, except thumbnails, which is by design. So I've created all the JPG thumbnail files, for the videos.
    at first I did:

    video.ext => video.jpg
    later i also tried:

    video.ext => video.ext.cover.jpg

    In both cases I then see the thumbnails on the (samsung) TV! but… then the videos don't play anymore. It seems then minidlna serves for the video the image/jpeg mimetype!

    i can also confirm this using the DK Dlna DLNA client on my android smartphone: the video plays fine until I add a thumbnail. Then when clicking the video, it asks whether to open it with the gallery or image viewer and says it's image/jpeg.

    I guess it's a very basic mistake on my part here but I couldn't find any proper documentation on this topic?

    Thank you!

    PS: on the same setup mediatomb has thumbnails and videos which play. however it doesn't have subtitles and restoring video play where you were…

  • Emmanuel Touzery

    i see others have had similar problems, but i didn't find a solution in that thread:

    as far as i can tell the poster gave up and moved to another DLNA server.

    so it seems it's a bug, not a misunderstanding on how to use the software from my part :-/

  • Saurav Ghosh

    Saurav Ghosh - 2012-09-20

    Sorry to dig up an old thread, but would really like to know if this ever fixed in the subsequent versions?  I think I have this problem where none of the videos with album art in the same folder would play on the client.   Videos that don't have any image files in the folder play just fine.  miniDLNA 1.0.22 is running on FreeNAS 8.2 (x86).

    Have tried XBMC on OSX and XBMC (by ZappoTV?) on iPad3.  The folder with Videos (in sub-folders) is added with a "V" prefix in minidlna.conf. 

    When I go inside the video folder, the client only lists an image and not the video file.  It doesn't actually render the image but a place-holder instead, with the mime-type indicating that its an image.  If I click (touch) the image, I expect it to play the video file that's surely there in that folder, but I get an error instead.   miniDLNA says "Client tried to specify transferMode as Streaming with an image". 

    I'm sure its not a codec problem because the same file in a folder without any images in it would play just fine on both clients. XBMC on OSX says something like "error probing input format <upnp URL>"

  • Grant

    Grant - 2012-11-20

    I have been having this problem as well (running 1.0.25 on ubuntu).  If there is a thumbnail image in the directory, I can see the image but not play the video under XBMC, Totem, and VLC (windows and linux) clients. 

    Interestingly, I can still play the videos on my WD TV Live, which is why I first thought this might be a bug with libupnp, rather than minidlna.

    Perhaps I'll try the patch up there (only one line of code changed) and see if I can get it working properly in these software.  If so, it should definitely go into the main code.

  • Saurav Ghosh

    Saurav Ghosh - 2012-11-21

    Actually, I don't know what to make of it.  When I access these same folders (with thumbnails etc) with my DLNA capable Blu-ray player (Oppo BDP-93), it can see the media files and play them just fine.  It doesn't fetch/render any thumbnails even if they are there, just the supported media files.

    This only seems to be a problem with those DLNA/uPnP clients which can render thumbnails.  Another problematic client I have found is an Android uPnP Media Controller app called MediaHouse.


Log in to post a comment.