#179 Non-embedded subtitles (.srt) don't show

open
nobody
None
5
2015-12-23
2013-02-07
krychek
No

I'm using MiniDLNA 1.0.24 (not .25 because it's not available in Ubuntu and OpenWRT) and most of my DLNA clients don't show non-embedded subtitles (.srt).
The name of the video and subtitle files are: a.avi and a.srt.

I have tested with 4 DLNA client with the following result:
- Skifta android app 1.57.07 - .srt does NOT show
- VLC 2.0.5 - .srt does NOT show
- Philips HMP7001/12 media player - .srt does NOT show
- LG LW650S television - .srt DOES show

Discussion

  • krychek

    krychek - 2013-02-07

    test subtitle file

     
  • krychek

    krychek - 2013-02-07

    I forgot to mention that embedded subtitles in .mkv files all work flawlessly.

     
  • krychek

    krychek - 2013-02-14

    I've contacted Philips to check this problem on their end.

     
  • krychek

    krychek - 2013-02-18

    I just tried BS player on android and .srt subtitles DON'T show either.

     
  • Peter Krnjevic

    Peter Krnjevic - 2013-06-24

    Same problem here with minidlna 1.1.0, built from source, on Ubuntu 12.04.2 LTS, using as client XBMC 12.2 on OS X 10.8.4.
    Name of .mkv and .srt files are the same (besides extension).
    Don't know if this is expected behaviour, but debug output only ever show .mkv files, and never .srt.

     
  • Justin Maggard

    Justin Maggard - 2014-04-28

    There is no universal standard for subtitles, so it has to be implemented on a client-by-client basis. If you know of any additional clients that do support subtitles, that don't work with ReadyMedia, then let me know.

    Right now we support Samsung devices, LG devices, BubbleUPnP (in git master, queued for 1.1.3), and any device that explicitly requests PacketVideo-style subtitles in their filter argument (at least Panasonic, maybe more).

     
  • nfj25

    nfj25 - 2014-09-26

    Hello, in my 2014 Sony Bravia, external srt subtitles don't work. But if embedded in the mkv it works ok (merged with mkvmerge for example). I'm using the version available in raspian, 1.0.24.

     
  • ofrias

    ofrias - 2015-12-01

    Hi. External srt subtitles do NOT work on a Samsung UE65JU7000. Any ideas to make this work?

     
  • Laurentiu Simin

    Laurentiu Simin - 2015-12-06

    Hello!
    I'm using the latest version (1.1.5) on my nas Zyxel NSA310 and I also confirm that external subtitles (.srt) don't work on Samsung Tv J series. I have Samsung UE48J5500 and I tested Universal Media Server on my PC and this server works. Too bad that they don't have an Arm version for my nas. So if you can fix this problem in a future version I'll be very happy. Maybe this forum topic from Universal Media Player can help: http://www.universalmediaserver.com/forum/viewtopic.php?f=9&t=3874 .

     
  • Shrimpkin

    Shrimpkin - 2015-12-07

    Run in debug mode and post the following debug info:
    1) Client profile. debug: Added client
    2) HTTP browse request of container w/external subs. debug: HTTP REQUEST and debug: Browsing ContentDirectory
    3) HTTP browse response of #2. debug: HTTP RESPONSE

    I would need that info to know what is going on. Post using preformatted text. For more help, look at formatting help.

     
    • ofrias

      ofrias - 2015-12-09

      Thanks a lot for your help. This is the requested debug info:

      [2015/12/09 17:23:22] clients.c:295: debug: Added client [Samsung Series [CDEF]/192.168.1.129/78:BD:BC:09:CE:6C] to cache slot 0.
      
      [2015/12/09 17:23:45] minidlna.c:1272: debug: HTTP connection from 192.168.1.129:50805
      [2015/12/09 17:23:45] clients.c:271: debug: Client found in cache. [Samsung Series [CDEF]/entry 0]
      [2015/12/09 17:23:45] upnphttp.c:880: debug: HTTP REQUEST: POST /ctl/ContentDir HTTP/1.1
      HOST:192.168.1.133:8200
      Accept: */*
      CONTENT-LENGTH: 458
      CONTENT-TYPE: text/xml; charset="utf-8"
      USER-AGENT: DLNADOC/1.50 SEC_HHP_[TV] UE65JU7000/1.0 UPnP/1.0
      SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
      Connection: close
      
      <?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:Browse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><ObjectID>64$0$5</ObjectID><BrowseFlag>BrowseDirectChildren</BrowseFlag><Filter>*</Filter><StartingIndex>0</StartingIndex><RequestedCount>200</RequestedCount><SortCriteria></SortCriteria></u:Browse></s:Body></s:Envelope>
      [2015/12/09 17:23:45] upnphttp.c:653: debug: SOAPAction: urn:schemas-upnp-org:service:ContentDirectory:1#Browse
      [2015/12/09 17:23:45] upnpsoap.c:1907: debug: SoapMethod: Browse
      [2015/12/09 17:23:45] upnpsoap.c:1211: debug: Browsing ContentDirectory:
       * ObjectID: 64$0$5
       * Count: 200
       * StartingIndex: 0
       * BrowseFlag: BrowseDirectChildren
       * Filter: *
       * SortCriteria: (null)
      [2015/12/09 17:23:45] upnpsoap.c:1303: debug: Browse SQL: SELECT o.OBJECT_ID, o.PARENT_ID, o.REF_ID, o.DETAIL_ID, o.CLASS, d.SIZE, d.TITLE, d.DURATION, d.BITRATE, d.SAMPLERATE, d.ARTIST, d.ALBUM, d.GENRE, d.COMMENT, d.CHANNELS, d.TRACK, d.DATE, d.RESOLUTION, d.THUMBNAIL, d.CREATOR, d.DLNA_PN, d.MIME, d.ALBUM_ART, d.DISC from OBJECTS o left join DETAILS d on (d.ID = o.DETAIL_ID) where PARENT_ID = '64$0$5'  limit 0, 200;
      [2015/12/09 17:23:45] upnphttp.c:1216: debug: HTTP RESPONSE: HTTP/1.1 200 OK
      Content-Type: text/xml; charset="utf-8"
      Connection: close
      Content-Length: 1340
      Server: Ubuntu DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.1.4
      Date: mié, 09 dic 2015 16:23:45 GM
      EXT:
      
      <?xml version="1.0" encoding="utf-8"?>
      <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body><u:BrowseResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><Result>&lt;DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/"&gt;&lt;item id="64$0$5$0" parentID="64$0$5" restricted="1"&gt;&lt;dc:title&gt;myfile&lt;/dc:title&gt;&lt;upnp:class&gt;object.item.videoItem&lt;/upnp:class&gt;&lt;dc:date&gt;2015-02-20T17:55:50&lt;/dc:date&gt;&lt;sec:dcmInfo&gt;CREATIONDATE=0,FOLDER=myfile,BM=0&lt;/sec:dcmInfo&gt;&lt;res size="576993989" duration="0:22:38.272" bitrate="424800" sampleFrequency="48000" nrAudioChannels="6" resolution="1280x720" protocolInfo="http-get:*:video/x-mkv:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000"&gt;http://192.168.1.133:8200/MediaItems/51436.mkv&lt;/res&gt;&lt;sec:CaptionInfoEx sec:type="srt"&gt;http://192.168.1.133:8200/Captions/51436.srt&lt;/sec:CaptionInfoEx&gt;&lt;/item&gt;&lt;/DIDL-Lite&gt;</Result>
      <NumberReturned>1</NumberReturned>
      <TotalMatches>1</TotalMatches>
      <UpdateID>37</UpdateID></u:BrowseResponse></s:Body></s:Envelope>
      
       
      Last edit: ofrias 2015-12-09
  • Laurentiu Simin

    Laurentiu Simin - 2015-12-07
    Post awaiting moderation.
  • Shrimpkin

    Shrimpkin - 2015-12-12

    @ofrias - Thanks for posting the info. Looks like minidlna is offering the subtitles using sec:CaptionInfoEx with the flag SEC_CAPTION_INFO_EX and looks OK.

    @lauryca - If you can post the HTTP response for UMS, it might be helpful. Although, a few grep's through UMS source code shows UseClosedCaption option uses sec:CaptionInfoEx too.

    If the responses are the same, there is not much more I can do to debug without access to the device. Maybe someone else is able? minidlna response is below:

    <?xml version="1.0" encoding="utf-8"?>
    <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
      <s:Body>
        <u:BrowseResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1">
          <Result>
            <DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/">
              <item id="64$0$5$0" parentID="64$0$5" restricted="1">
                <dc:title>myfile</dc:title>
                <upnp:class>object.item.videoItem</upnp:class>
                <dc:date>2015-02-20T17:55:50</dc:date>
                <sec:dcmInfo>CREATIONDATE=0,FOLDER=myfile,BM=0</sec:dcmInfo>
                <res size="576993989" duration="0:22:38.272" bitrate="424800" sampleFrequency="48000" nrAudioChannels="6" resolution="1280x720" protocolInfo="http-get:*:video/x-mkv:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01700000000000000000000000000000">http://192.168.1.133:8200/MediaItems/51436.mkv</res>
                <sec:CaptionInfoEx sec:type="srt">http://192.168.1.133:8200/Captions/51436.srt</sec:CaptionInfoEx>
              </item>
            </DIDL-Lite>
          </Result>
          <NumberReturned>1</NumberReturned>
          <TotalMatches>1</TotalMatches>
        </u:BrowseResponse>
      </s:Body>
    </s:Envelope>
    
     
    • ofrias

      ofrias - 2015-12-14

      So, does that mean that this is a bug in Samsung TV?

      Is there a way to report this to Samsung technical team?

       
  • Shrimpkin

    Shrimpkin - 2015-12-16

    User lauryca hasn't responded with the info. You might try UMS and check if subs are working. If so, post the response that UMS sends. As far as I know, if the subs are being offered correctly it's up to the client to use them.

     
  • krychek

    krychek - 2015-12-17

    You guys should just stop using DLNA altogether. It's a horrible product. Just use SMB or FTP servers to reach your videos. If your TV doesn't support it then just buy an Android TV Box. It's really not that expensive and it will play everything with Kodi via SMB or FTP or whatever.

     
  • Shrimpkin

    Shrimpkin - 2015-12-21

    Since the previous posters hijacked an old thread, post any additional comments related to Samsung J Series here:
    http://sourceforge.net/p/minidlna/feature-requests/113/

     
    Last edit: Shrimpkin 2015-12-21
  • ofrias

    ofrias - 2015-12-23

    OK. I have moved all the info that I posted related to J Series to the other issue. I have also tested external subtitles with UMS and they work. All the information is here:

    http://sourceforge.net/p/minidlna/feature-requests/113/

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks