Can you explain further? If the compiler is now able to find the iostream header, what problem are you having with your actual software? More importantly, which of Greg's suggestions actually fixed the problem with hello.cpp?
 
Luke
 
----- Original Message -----
From: Randy Miles
To: MinGW Users
Sent: Friday, May 02, 2003 5:12 AM
Subject: Re: [Mingw-users] missing namespace std?

Well, that advice worked to compile hello.cpp. Unfortunately, I still am having trouble with the program I care about, but I've reverted back to mingw32 which does the job for me. Thanks for your help.

Greg Chicares wrote:
[Please post plain text instead of html--thanks]

  
Randy Miles wrote:

I downloaded the file MinGW-2.0.0-3.exe from http://www.mingw.org/download.shtml. I then ran the self-extractor to install. I put
the \bin directory on my path, just before cygwin\bin (which I use for its utilities). Then I tried to run g++ from a dos prompt.
Is there something I am missing?
    

Make sure you haven't defined any special gcc
environment variables like 'GCC_EXEC_PREFIX'.

Make sure you undo any previous changes to
system headers.

Make sure you don't have a file named 'iostream'
in the current directory, or a file named
'header.gcc'.

Take cygwin off the path.

In fact, set the path to include only your MinGW/bin
directory, and nothing else--at the command line,
immediately before executing g++ to compile your
'hello' program.

If none of this helps, then add '-H' to your g++
options to show where it's getting its headers,
then inspect the 'iostream' file in the directory
it indicates.

Don't discount what Oscar said:

  
  hello.cpp: `cout ' undeclared in namespace `std'
      
                    ^
____________________| 

Seems you have an invisible character there. Please re-type the source
code and compile again.
    

You should not see that stray character after 'cout'.
  

------------------------------------------------------- This sf.net email is sponsored by:ThinkGeek Welcome to geek heaven. http://thinkgeek.com/sf _______________________________________________ MinGW-users mailing list MinGW-users@lists.sourceforge.net You may change your MinGW Account Options or unsubscribe at: https://lists.sourceforge.net/lists/listinfo/mingw-users