Hello together,

 

very much thanks for that helpful instruction:

HOWTO compile and use the mpatrol memory leak detection library

 

I tried to keep very strictly to it and was "almost" succesful up to the end.

 

But I get errors, if I try to link, using the command:

g++ -g -lmpatrol -lbfd -liberty -lintl -limagehlp -o main.exe main.o

 

I get the error mesage:

 

c:/mingw/include/mpatrol.h:1061: undefined reference to `__mp_alloc'

collect2: ld returned 1 exit status.

 

The libraries are all existent and are found, (compiling also without errors).

 

The only "abnormal" behaviour during the make process was an unknown

switch "-mno_cygwin", where the make process stopped.

 

Because we use mingw here anyway (and I havn't installed Cygwin at all),

I deleted all occurences of "-mno-cygwin". After that, I run through "make"

and "make install" without errors.

 

Finally, I copied all files below "local" into the mingw-directories.

 

So far I ended up.

I searched for "mpatrol __app_alloc" also in this discussion group,

but all, what I got, was http://tech.groups.yahoo.com/group/mpatrol/message/803

with no further help for me.

 

So I would be pleased, if anybody has any idea, what can I do further.

 

Is it possible, that my error has somehing to do with the unknown "-mno-cygwin" switch?

 

Do I miss a library due to the "undefined reference to `__mp_alloc'", but which library

could that be (I linked to all, what I found in the mpatrol.pdf document.)

Any other idea?

 

Thanks for giving your time

Gerhard

 



Sitz: Backnang; Registergericht: Amtsgericht Stuttgart HRA 270977
Persoenlich haftender Gesellschafter: Tesat-Spacecom Geschaeftsfuehrungs GmbH;
Sitz:Backnang; Registergericht: Amtsgericht Stuttgart HRB 271658;
Geschaeftsfuehrung: Peter Schlote, Matthias Spinnler, Jochen Huppert