2012/10/29 Andrew <notes@shaw.ca>
From: Renato Silva [mailto:br.renatosilva@gmail.com]
Sent: Sunday, October 28, 2012 11:26 PM

> Aren't you installing it through mingw-get?

I have tried it without (using only mingw-get-inst) and with it.

> Also, I suppose you're running cmd.exe, so how
> about launching it from within rxvt, then bash?

If I double-click rxvt, I can then run sh or bash from within it, the same
as if I run rxvt from cmd.exe

Ok, but as I have asked, how about launching *cmd.exe from rxvt, then bash*?
 
> How about mintty?

I hadn't tried it, but just grabbed it and tried it, and it starts up fine
and gives me the prompt.


So as you can have it working file with both rxvt and mintty, it seems some odd issue with cmd.exe.
 
I wondered if anything ever wrote to something in like
c:\users\andrew\something... since that might survive uninstalls and
directory deletions - though I don't see anything obvious in there.


Try the procmon utility, run your problematic msys.bat or whatever then catch all file paths it reads, then export to csv, open it in some spreadsheet editor and sort by the path column, then check what you see there.