2012/10/28 Andrew <notes@shaw.ca>



I installed MinGW some time back and recently uninstalled and reinstalled the latest version of MinGW and msys.


When I tried to run msys.bat I get a "logout" on the prompt line and it exits. When I tried to run either sh, or bash, I get an "exit" on the prompt line and the shell exits immediately.


I then uninstalled to install a clean msysgit. However, I get the same results from msys.bat, sh, and bash. However, this time I have rxvt.exe, which I can run without any apparent problem (and without it immediately exiting, of course!)


I suspect maybe some left-over config file(?) from my initial installation in which I did something stupid, but I don't know much about this environment… I don't see any .bashrc or similar files, at least in my MinGW/msysgit directories.


Any thoughts or suggestions would be much appreciated.  I pretty much don't know what I'm doing, so please don't hesitate to point out the blindingly obvious.  ;)





Hi Andrew,

I would try to install MinGW and MSYS on a totally separate folder, and be sure to not have stuff from old installation in system path (by renaming the old directories and taking a look on how the Windows path looks like).

My guess is that there's an exit command in some of the bash initialization scripts, such as /etc/profile or ~/.profile, which isn't getting overwritten or ignored in your new installations. Try to inspect those files from rxvt, and make sure mount isn't referencing old stuff (I think sometimes you need to reboot/logout to some mount changes to take effect).