On 23 August 2013 10:34, Uwe Rossow wrote:
Hi!

Am 22.08.2013 22:50, schrieb Keith Marshall:
> mingw-get.exe should be capable of upgrading itself; this has always
> worked for me.  Updating the catalogue has occasionally failed on random
> files, but two or three reruns has always given full coverage.

I tried that in the last months a couple of times and it failed to work.
Everything went fine (automatically upgrading) until mingw-get-0.4...

This puzzles me; the upgrade should have been to 0.5...
 
> If you run the CLI
>
>    mingw-get --version
>
> does it show the same version as you see in the Help/About... box-out
> from the GUI?  If so, then the two should be running identically the
> same code, in identically the same mingw-get-0.dll, to perform the
> downloads and installation of packages.

Yes, positive. It doesnt show the 404 errors when using the batch file.

Now it shows the correct version 06.

Sorry.  That seems ambiguous.  Are you saying that with the old 0.4 CLI
client, you were beset by 404 errors, but they went away when you used
0.6.0, (both CLI and GUI)?  If so, then it does seem that the connection
throttling code, introduced in version 0.6.0, does mitigate the issue.

However, for some reason mingw-get... lic and pkginfo
dont work even with the gui saying:
*** ERROR *** due to previous download failure

Although it appears to be superficially similar, this is a different
issue -- an inconsistency between the files advertised in the catalogue
bundled with mingw-get-setup-0.6.0-20130806-1, and those actually
available on the download server.  This should now be fixed, if you
download the latest (20130823-1) mingw-get-setup.exe[1], run it, and
select the "Reinistall" option, when it is offered.

[1]: https://sourceforge.net/projects/mingw/files/latest/download?source=dlp

--
Regards,
Keith.