Thanks for any help you can give me. I just started learning C++ and man what an adventure it's been so far. Anyway, I use the most recent release of Code::Blocks with the MinGW compiler. I tried writing a program for an exercise in the book I'm reading, C++ Primer Plus by Stephen Prata, but I am getting a compiler error. Namely, this :

c:\program files (x86)\codeblocks\mingw\bin\..\lib\gcc\mingw32\4.4.1\include\c++\c++0x_warning.h|31|error: #error This file requires compiler and library support for the upcoming ISO C++ standard, C++0x. This support is currently experimental, and must be enabled with the -std=c++0x or -std=gnu++0x compiler options.|

Now I have the -std=c++0x flag enable in the compiler options, and I tried adding the -std=gnu++0x one to the command line for the executable, but it still throws that error. So, I'm wondering if the version of MinGW I'm using supports the array class that came out with C++11 or not? It looks like the version on the installer that came with Code::Blocks is 1.908.0-4.4.1-2. Thanks again for the help!

Ray Boyer