On Friday 02/15/2013 at 15:38:17, LRN wrote:
Hash: SHA1

On 15.02.2013 22:02, Bill Blue wrote:
I'm stuck on msys-apr-util. I started off with the recommended
apr-util-1.3.12-3 which fails in numerous places (during configure
and make), and also tried the latest from Adobe, apr-util-1.5.1. It
needed to know where the installed apr was (/bin). After a
buildconf and configure which seemed to go ok, doing a make,
resulted in:

$ make make[1]: Entering directory `/src/msys/apr-util-1.5.1'
/bin/sh /share/apr/build-1/libtool --silent --mode=compile gcc
-I/src/msys/apr-util-1.5.1/include/pr ivate
-Ic:/STRAWB~1/c/include -I/include/apr-1 -o
buckets/apr_brigade.lo -c buckets/apr_brigade.c && touch
buckets/apr_brigade.lo In file included from
/usr/include/asm/socket.h:14, from /usr/include/cygwin/socket.h:23,
from /usr/include/sys/socket.h:15, from /include/apr-1/apr.h:170,
from buckets/apr_brigade.c:17: /usr/include/cygwin/if.h:78: error:
parse error before "caddr_t" /usr/include/cygwin/if.h:80: error:
parse error before '}' token /usr/include/cygwin/if.h:82: error:
parse error before '}' token

The original version of apr-util tried had similar types of errors
which seemed to center around this section, as it was repeated
several times:

/usr/include/cygwin/if.h:78: error: parse error before "caddr_t"
/usr/include/cygwin/if.h:80: error: parse error before '}' token
/usr/include/cygwin/if.h:82: error: parse error before '}' token

Can anyone suggest a possible solution to getting this compiled?
See [1] for some clues.

Are you referring to the possible compiler syntax errors?  This reference is from 2001, so I'd be doubtful that any of it applies to today...

All i can say is that msys-apr-util-1-1.3.12-4 compiles just fine for
me. If you want more automation, you might want to try [2] (which is
basically a scripted version of [3]).

And just to be clear: i am not affiliated with mingw.org, and the
stuff i provide is just that - my stuff.

And that is much appreciated!  I used your patches to libpgp-error (mingw) which fixed problems I was having with it.  But msys-apr-util-1-1.3.12-4 is not the whole src, just some patches to (?).  I compared the patches to 1.3.12-3 that I was using, and they appear to be the same.  And after applying your patches in a fresh src of 1.3.12-3, the build errors were exactly the same as I've been experiencing (above).

I'm usually on freenode, in case you need some advice.

[1] http://curl.haxx.se/mail/archive-2001-12/0065.html
[2] https://www.gitorious.org/sbuild#more
[3] http://gstreamer.freedesktop.org/wiki/SettingUpMinGWMSysEnvironment

My msys environment seems to contain all the items from mingw-get that you list in [2], so i'm not sure why I'm seeing different behavior.